Hydroboost experts? - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 05-26-2009, 03:18 AM Thread Starter
Registered User
 
2k2GT's Avatar
 
Trader Feedback: (0)
Join Date: Aug 2002
Location: Lenoir City, TN
Posts: 6,493
Hydroboost experts?

This system is all complicated and confusing to me, so please forgive my ignorance.

How should this system be "flushed"? I've searched and seen some people do a flush their self, and other say you need a machine to suck it out....and Hell, I think there were 2 or 3 other ways I read besides those.

I haven't changed out the PS fluid....ever, since I bought the car new in 2002 and it's been 7 years and 40,000 miles on it. It looks very very dark, maybe brownish in color. Hard to tell.

I did boil the brake fluid pretty bad at the track event this weekend and thats the first time i've ever had that happen to me. Does this in any way relate to the PS fluid used for the hydroboost?

The steering feels fine, or has felt like it always has....maybe it's a little "thicker" when steering quickly, maybe it's in my head.

Any advice or links to some answers would be appreciated, thanks.

2k2GT is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 05-26-2009, 06:43 AM
Registered User
 
d90212's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2000
Location: kailua, hawaii
Posts: 394
Power Steering System Flushing

WARNING: Do not mix oil types. Any mixture or any unapproved oil can lead to seal deterioration and leaks. A leak can ultimately cause loss of fluid, which can result in a loss of power steering assist. Failure to follow these instructions may result in personal injury.

Remove the power steering fluid reservoir cap.
Using a suitable suction device, remove the power steering fluid from the reservoir.
Disconnect the power steering fluid return hose from the reservoir.
Remove the clamp.
Plug the reservoir inlet port.
Attach an extension hose to the power steering return hose.
NOTE: Do not reuse the power steering fluid that has been flushed from the power steering system.

Place the open end of the extension hose into a suitable container.
CAUTION: Do not overfill the reservoir.

Fill the power steering fluid reservoir with clean fluid.
CAUTION: Do not allow the power steering pump to run completely dry of power steering fluid.

Start the engine while simultaneously turning the steering wheel to lock and then immediately turn the ignition to OFF.
CAUTION: Avoid turning the steering wheel without the engine running as this may cause air to be pulled into the steering gear.

CAUTION: Do not overfill the reservoir.

Fill the power steering fluid reservoir with the approved power steering fluid.
Repeat Steps 8 and 9, turning the steering wheel in the opposite direction each time, until the fluid exiting the power steering fluid return hose is clean and clear of foreign material.
Remove the extension hose from the power steering return hose.
Remove the plug from the power steering fluid reservoir inlet port.
Install the power steering return hose to the reservoir.
Install the clamp.
NOTE: It is necessary to properly fill the power steering system to remove any trapped air and completely fill the power steering system components.

If after properly filling the power steering system there is power steering noise accompanied by evidence of aerated fluid and there are no fluid leaks, it may be necesaary to purge the power steering sytem. For additional information, refer to Power Steering System Purging in this section.


Fill the power steering system.



Personally...Id just use a 1/2 quart suction gun...or brake bleeder kit...and suck it down low.....fill...then actuate the brakes and steering from lock to lock...and keep repeating the process...



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Let the Fox 4.6 Conversion Begin!
wifes ride
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

my fake snake 89 svt cobra-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
d90212 is offline  
post #3 of 9 Old 05-26-2009, 06:58 AM Thread Starter
Registered User
 
2k2GT's Avatar
 
Trader Feedback: (0)
Join Date: Aug 2002
Location: Lenoir City, TN
Posts: 6,493
Sounds like a time consuming pain. I'll print this page off and take it with me in the garage.

Thanks!
2k2GT is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 05-26-2009, 07:39 AM
Registered User
 
Trader Feedback: (0)
Join Date: Aug 2002
Location: winston salem
Posts: 1,382
I pulled my return line loose at the cooler at the lower left side of the radiator ,plugged the line and put a hose on the hard cooler line which I stuck in my oil drain pan then did the run,turn and fill routine.
j rick kirby is offline  
post #5 of 9 Old 05-26-2009, 07:40 AM
Registered User
 
d90212's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2000
Location: kailua, hawaii
Posts: 394


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Let the Fox 4.6 Conversion Begin!
wifes ride
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

my fake snake 89 svt cobra-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
d90212 is offline  
post #6 of 9 Old 05-26-2009, 09:13 PM
Registered User
 
Han Solo's Avatar
 
Trader Feedback: (2)
Join Date: Apr 2004
Location: Miccosukee, FL
Posts: 1,417
Read your owners manual to confirm but mine calls for MerconV.

99 Mustang GT - Auto-x/track car, 96 Townsend Chassis Late Model Stockcar (sold), 03 F150 - Daily Driver
http://www.youtube.com/user/sandyman099/videos
Han Solo is offline  
post #7 of 9 Old 05-26-2009, 09:34 PM Thread Starter
Registered User
 
2k2GT's Avatar
 
Trader Feedback: (0)
Join Date: Aug 2002
Location: Lenoir City, TN
Posts: 6,493
I'll see if I can find it. Who knows, Ford may've switched "recommendations" 3 or 5 times since 2002.
2k2GT is offline  
post #8 of 9 Old 05-27-2009, 07:47 AM
Registered User
 
huesmann's Avatar
 
Trader Feedback: (6)
Join Date: Jul 2004
Location: DC burbs, MD side
Posts: 6,894
Yeah, you gotta read all the TSBs and whatnot that have come out since your car was made. Ferinstance, I think they're recommending 5w20 oil nowadays instead of 10w30.
huesmann is offline  
post #9 of 9 Old 05-27-2009, 07:54 AM Thread Starter
Registered User
 
2k2GT's Avatar
 
Trader Feedback: (0)
Join Date: Aug 2002
Location: Lenoir City, TN
Posts: 6,493
I think it says 5w-20 on my oil cap, but I never could find it here in my town so I always put 5w-30 in there. My last few oil changes i've seen it the 5-20 pop up from time to time.

Not to mention the gay TR3650 trans that has more oil options(opinions) than a political debate.
2k2GT is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hydroboost 1Nasy03Snake Suspension 2 08-21-2008 04:01 PM
Hydroboost ? Deece 5.0/5.8 Engine Tech 0 02-12-2007 07:29 PM
hydroboost 89 5.0 vipjckmustang General Mustang Tech 1 03-01-2006 10:12 PM
NEED SOME HELP WITH HYDROBOOST foxlincoln SVT & DOHC 3 01-04-2006 09:03 PM
Hydroboost? LXguy S-197 Mustang (2005-2010) 1 03-02-2005 10:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome