poor running stang - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-14-2002, 05:49 AM Thread Starter
 
Trader Feedback: (0)
Join Date: Apr 2002
Posts: 310
poor running stang

my car runs great one day, the next day it seems like when it shifts it drags the motor down, it can happen in any weather, kinda strange. full throttle seems to work OK, it is just when cruising around. can't tell if is shifting weird or if the timing is getting pulled.......anybody have similiar problems? p.s. automatic trans

rottn1 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-14-2002, 05:56 AM
 
Trader Feedback: (0)
Join Date: Jul 2001
Posts: 1,724
When is the last time you changed your tranny fluid/filter.
Have the entire system emptied and refilled with synthetic fluid.
It will last longer run cooler and sap less energy from the engine.

46GTSblown is offline  
post #3 of 3 Old 05-14-2002, 12:45 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Apr 2002
Posts: 310
did tranny fluid at 40k, now have 75k. fluid doesn't look to bad, but I was kinda leaning this way, since its about time for a change anyhow. just hope it works, it's kinda annoying .
rottn1 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome