Aftercooled S-trim riddle - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-13-2002, 10:50 PM Thread Starter
 
Trader Feedback: (0)
Join Date: May 2001
Posts: 28
Aftercooled S-trim riddle

If anyone can figure this out Ill be surprised and greatful.

Bought my 2000 GT a year ago. Last summer I started having ping at WOT around 6000rpm.
My first thought was the hot weather... still did it when the weather was below 60 degrees.
My second thought was fuel octane (91 here in Cal.) I tried race gas 104 unleaded and Torco additive... no help.
So... I ordered the Vortech fuel and boost gauges, and... I showed no boost! I have a buddy here in town with a Vorteched 2001, he brought his car over and we re-hooked everything up just like his unit (done down at Vortech) Showed 4lbs boost on the on ramp for a second and then ...no boost, still pinged though!
Got under the car and noiticed the return hose AFTER the bypass valve was completely blown off! (NO hose clamps on that side.)
Sooo... I put on clamps and... voila , no more ping.

Now its easy to guess why it was pinging... air was entering the intake without passing through the Mass Air,; this would cause a lean condition, right?
Heres the strange part. Now, for the first time, the car shows boost! Only 5lbs. though. Vortech says it should show 10.

Any thoughts?

2000 Gt
5spd
Vortech S trim
Vortech aftercooler
38lb.(red) injectors
JBA shorties
Bassani catted X
Classic Design side pipes
T-rex

2000GT Vortech is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-13-2002, 10:55 PM
 
Trader Feedback: (0)
Join Date: Aug 2000
Posts: 109
Your losing a little bit of boost due to the aftercooler (assuming your reading boost from the manifold) and the advertised numbers from Vortech are just that..they will differ between cars. Though you may want to make sure you don't have another air leak somewhere and your belt maybe slipping some.

Sebastian

Sebastian is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome