97 Cobra--- backfired????? - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 04-19-2002, 11:49 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Mar 2002
Location: Houston
Posts: 313
97 Cobra--- backfired?????

I hit the gas and about 6000 rpm I hear a bang.

Car hasn't acted funny since. I just installed BBK h-pipe.

Did fuel accumulate in the h-pipe???????

Any damage????

KeithCobraUH is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 04-20-2002, 12:46 AM
Registered User
 
Blown284's Avatar
 
Trader Feedback: (21)
Join Date: Dec 1999
Location: Pasadena, Maryland USA
Posts: 7,628
Backfiring as far as I know normally occurs when you're running very rich. Try resetting your computer and see if that helps out things so the computer will relearn things (that is, if you haven't done this already).


SOHC/DOHC Corral Moderator
Founder,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Part-Owner,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'00 Ford F-350 7.3 Turdbo Diesel
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'03 Droptop Cobra
'99 Cobra "10 Second Street car" (SOLD!)
Blown GT ([email protected]) ---> SOLD
'00 Camaro (Couple of bolt-ons) - [email protected] (Jun 2011).
AOL: Blown284
Blown284 is offline  
post #3 of 9 Old 04-20-2002, 11:59 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Mar 2002
Location: Houston
Posts: 313
Thanks for the reply, I haven't reset it yet but have recently.

I figured it was caused by running rich.

Wierd for it to be so rich with not many mods----maybe MAC cold air is affecting MAF readings????
KeithCobraUH is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 04-20-2002, 01:09 PM
 
Trader Feedback: (0)
Join Date: Mar 2002
Posts: 52
When I put my MAC cold air on my GT, I noticed that the pipe can slide in pretty far. I'm wondering if the pipe is too far in that there could be turbulence issues causing the MAF to mis-read.
98PONYEXCESS is offline  
post #5 of 9 Old 04-20-2002, 02:52 PM
 
Trader Feedback: (0)
Join Date: Nov 2001
Posts: 77
backfire

mine backfires around there two. 6-6.500. when i shift it backfires, whatching some footage from the track i have fire shooting out the tailpipe! i tried resetting the computer and nothing. new plugs and wires and still did it. i have a bbk' off road h also. i guess im just running really rich???
mikesslow50h is offline  
post #6 of 9 Old 04-20-2002, 03:21 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Mar 2002
Location: Houston
Posts: 313
I guess I need to get a chip so that it can lean it out.
KeithCobraUH is offline  
post #7 of 9 Old 04-20-2002, 07:35 PM
Registered User
 
Trader Feedback: (0)
Join Date: Dec 2001
Location: Westchester, IL
Posts: 155
Mine shoots fire also. Only on the 1-2 shift at ~6600rpm. It started when I got the off-road x-pipe. My mechanic said all the 4.6 cobras run very rich from the factory, especially at high rpm. With no cats to burn up all the extra fuel when you shift, the fuel can get ignited when air gets in their. The only thing that will cure this is to fix the rich mixture using a chip.

John Dimitropoulos
http://www.johndimo.com
Modular John is offline  
post #8 of 9 Old 04-20-2002, 07:37 PM
Registered User
 
COBRA90GT's Avatar
 
Trader Feedback: (4)
Join Date: May 2001
Location: HOCKEYTOWN ® MI
Posts: 3,557
Lightbulb

Quote:
Originally posted by 97cobracpe
Mine shoots fire also. Only on the 1-2 shift at ~6600rpm. It started when I got the off-road x-pipe. My mechanic said all the 4.6 cobras run very rich from the factory, especially at high rpm. With no cats to burn up all the extra fuel when you shift, the fuel can get ignited when air gets in their. The only thing that will cure this is to fix the rich mixture using a chip.

The above explanation is your answer....it's just igniting downstream... (off-road pipe)

'01 Cobra Coupe From 6.01 - 9.15
'94 Cobra Coupe From 9.09 - 6.11
'14 F-150 Raptor SCAB Deliv 3.14
COBRA90GT is offline  
post #9 of 9 Old 04-22-2002, 03:30 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Mar 2002
Location: Houston
Posts: 313
My car didn't backfire the last time I got to 6000, but it hesitated.

Is this caused by it running rich?

New plugs help?
KeithCobraUH is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome