What is going on with my 96 Cobra??? - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 04-16-2002, 03:10 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Nov 2001
Posts: 88
What is going on with my 96 Cobra???

Ok, I just drove up to the bank, its about a mile up there. It is about 78 degrees here. My car was just started up today for the first time since last night. I probably didn't get over 40 mph and hit about 6 stoplight going and coming. My car was all the way on M on my temp gauge?? I recently got my car rebulit at True Blue Performance and am suppose to go back on Friday for some more tuning. Should I call them and see why my car got so hot on like a 10 minute trip??? I am suppose to autocross on Sunday for the first time since the reuild and now I am scared to if it is going to get real hot. Also at idle my supercharger whine surges. It also "sticks" at around 1800 after i come to a stop with my foot on the clutch. Randy at True Blue said that he has the "timing locked out" and that is why it idles funny. Has anyone had any experience with this. What the heck

Dave

Blown96Snake is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 04-16-2002, 03:28 PM
Corral Charter Member
 
Cobra Jet NJ's Avatar
 
Trader Feedback: (41)
Join Date: Mar 2000
Location: NJ
Posts: 11,141
You have no mention as to if your 96 Cobra still has the factory issued cooling system - OR if you have something aftermarket, OR if your 96 had the Ford TSB/recall/fix issue done to the cooling system.

My guess is this, with the limited info above:

1) you Cobra still has the stock cooling system, which is inadequate

2) your thermostat could be stuck

3) the cooling system may have air pockets in it after the rebuild and those need to be burped out

post back what is done to your cooling system, if anything.

Cobra Jet NJ is offline  
post #3 of 5 Old 04-16-2002, 05:21 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Nov 2001
Posts: 88
It hasn't had the cooling fix. Would that be causing it to idle funny too?

Dave
Blown96Snake is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 04-17-2002, 02:00 AM
 
Trader Feedback: (0)
Join Date: Feb 2001
Posts: 101
IMO

1. Change the radiator to a Steeda or Fluidyne

2. Change water pump to one from Evans

3. Use water wetter in the system

4. Install 180* thermostat and either a manual switch or auto fan controller set to come on around 165 to 170*. (The motor will still produce enough heat to get to the proper operating range)

5. Get all of the air out of the cooling system. This is a must.

6. for surging idle. With no engine codes. check that egr is fully closed. Pull the vacuum line to the egr valve. There should be no vacuum on the line at idle. If there is change the egr regulator it may be leaking a bit which will open the egr slightly at idle and cause a poor idle.

7. remove IAC and check for carbon buildup inside. Clean and reinstall.

Let us all know what you find.

Good luck

This all assumes that you have a proper tune with the 42 pounders. I've heard of others having idle issues with large injectors.

Last edited by sirhisss; 04-17-2002 at 02:03 AM.
sirhisss is offline  
post #5 of 5 Old 04-17-2002, 04:14 AM
 
Trader Feedback: (0)
Join Date: Jun 2000
Posts: 478
Keep the stock water pump. The evans flows to much water. Steeda radiator definately.
Venomous Mofo is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome