Oil pressure at highway speeds - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 01-12-2019, 10:15 AM Thread Starter
Registered User
 
Rolltide1006's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2017
Posts: 67
Oil pressure at highway speeds

Hello all and I apologize if this issue I am having has been answered before. I canít find my particular issue discussed on google Oil is full and is Motorcraft 5w-20 with a Motorcraft oil filter. Wiring to the autometer gauge is

I have a 97 GT and hooked up a autometer oil pressure gauge to know where I am at. The motor is a 4.6 2v and has PI heads, blower cams and was rebuilt 2k miles ago. Oil pressure is 70-80psi on cold start and I never lose it or see it drastically change. When nice and hot, I am idling with 20-25 psi. Once i bump the throttle it shoots to 50 psi. When I accelerate hard from a stop I see a nice gradual climb with pressure all the way to 60-70 psi. When I am driving on the highway is when I notice a slight fluctuation. When I am going 70-75mph in 5th gear at about 2200 rpm I noticed the meter was at 50 psi. I give it throttle and the needle will drop slightly down to about 45 psi and once I let off the throttle it will jump back to 50 psi. When I am at the same speeds and drop it into 3rd and accelerate the pressure goes to 55 and doesnít climb as quick as it does when I am messing around in town. This is my first time having a aftermarket oil pressure gauge so I may be just a little paranoid. Just wanted to hear yalls opinions and/or experiences. Am I crazy or what? Thanks in advance!


Sent from my iPhone using Tapatalk Pro

Rolltide1006 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 01-12-2019, 10:25 AM Thread Starter
Registered User
 
Rolltide1006's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2017
Posts: 67
Is this normal?


Sent from my iPhone using Tapatalk Pro

Rolltide1006 is offline  
post #3 of 10 Old 01-16-2019, 09:25 AM
Registered User
 
Pony Problem's Avatar
 
Trader Feedback: (0)
Join Date: Nov 2010
Location: Eastern Oklahoma
Posts: 21
Cold pressure seems just a tad high for 5w20, but I’m not concerned. That’s quite healthy so I certainly wouldn’t be worried about a lack of pressure.

09 H/C/I/E Z06 SOLD / 02 Blown GT / 73 C10 6.0 Swap
Pony Problem is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old 01-16-2019, 09:44 AM
Registered User
 
Trader Feedback: (1)
Join Date: Dec 2015
Location: Rush, NY
Posts: 2,206
None of that looks like an issue to me. Not the same engine but I had a '90 302 with a mechanical gauge and it was the same kind of pressures and behaviors. So I would be inclined to think that's normal.

Only weird thing is the slight drop and climb at highway speed you describe...hence your concerns. If you are in 4th at a steady 2200 rpm and add throttle does it to the same thing?
tjm73 is offline  
post #5 of 10 Old 01-16-2019, 09:59 AM Thread Starter
Registered User
 
Rolltide1006's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2017
Posts: 67
Quote:
Originally Posted by tjm73 View Post
None of that looks like an issue to me. Not the same engine but I had a '90 302 with a mechanical gauge and it was the same kind of pressures and behaviors. So I would be inclined to think that's normal.



Only weird thing is the slight drop and climb at highway speed you describe...hence your concerns. If you are in 4th at a steady 2200 rpm and add throttle does it to the same thing?


I need to double check 4th at 2200 rpm to be 100%, but if my memory is correct it does the same thing.


Sent from my iPhone using Tapatalk Pro
Rolltide1006 is offline  
post #6 of 10 Old 01-16-2019, 03:37 PM Thread Starter
Registered User
 
Rolltide1006's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2017
Posts: 67
Just changed the oil. Im still showing fine metal material in the oil (less than 5k miles on the rebuild). We will see what happens on my ride home from work tonight


Sent from my iPhone using Tapatalk Pro
Rolltide1006 is offline  
post #7 of 10 Old 01-16-2019, 06:00 PM Thread Starter
Registered User
 
Rolltide1006's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2017
Posts: 67
Motor has a slight tap around cylinders 7-8. Have to drop the motor again


Sent from my iPhone using Tapatalk Pro
Rolltide1006 is offline  
post #8 of 10 Old 02-01-2019, 09:56 AM
Registered User
 
98GT225's Avatar
 
Trader Feedback: (0)
Join Date: Jan 2019
Location: Raleigh NC
Posts: 7
Ouch sorry to hear that
98GT225 is offline  
post #9 of 10 Old 02-01-2019, 10:01 AM Thread Starter
Registered User
 
Rolltide1006's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2017
Posts: 67
Quote:
Originally Posted by 98GT225 View Post
Ouch sorry to hear that


Ya, no good. I never lost oil pressure, but I donít know what happened. I hope the machine shop can find and fix this issue. I didnít think using aftermarket internals would be this difficult to keep running.


Sent from my iPhone using Tapatalk Pro
Rolltide1006 is offline  
post #10 of 10 Old 02-01-2019, 11:35 AM
Registered User
 
lwarrior1016's Avatar
 
Trader Feedback: (5)
Join Date: Dec 2013
Location: Mississippi
Posts: 695
It’s not any more difficult than factory internals. It all depends on assembly and attention to detail.

Question, what oil pump did you use?

lwarrior1016 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure problem dbldrew 5.0/5.8 Engine Tech 6 11-21-2013 08:43 AM
State says many drivers change oil too often hellbound911 Lounge 49 02-11-2008 11:38 AM
Is there an authority on fuel systems on here? KennethWW SVT & DOHC 27 08-13-2007 04:06 PM
Bizzare Oil Pressure Issue RedNotch1991 5.0/5.8 Engine Tech 7 06-28-2004 03:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome