Timing at idle causing too get hot fast - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-20-2015, 08:14 AM Thread Starter
Registered User
 
sprayed347's Avatar
 
Trader Feedback: (13)
Join Date: Jan 2005
Location: st.louis
Posts: 636
Timing at idle causing too get hot fast

I have a 93 lx with a 306 9.8to 1 edelbrock performer heads cobra intake.on3 kit f cam moates with b.e.has a large alum. Radiator and cooling fans.this thing gets to 180 in less than 10 minutes of idle time.Iam re wrapping all the pipes.but I took a data log of it just idling from start to 180 to confirm guage accuracy.noticed air fuel was 14.5 to 14.9 and timing was at 30 deg the whole time would a little more timing and fuel at idle help combat this getting hot fast issue?it seems lean with not enough timing to me.but iam no tuner.

sprayed347 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-24-2015, 02:10 AM
Registered User
 
toyman's Avatar
 
Trader Feedback: (8)
Join Date: Aug 2007
Location: BC
Posts: 2,433
I'm missing something. Getting up to operating temperature quickly should be a good sign. What is your concern?


Richard

KB 2.1L @ 9psi, FRPP M5400-A Suspension System, FRPP Aluminum D/S, Built AODE and TC, FRPP 3.73 Gears, Balanced Roller Cammed Engine, Edelbrock Performer Heads, Comp 270AH cam, AEM EMS, 3.5 Bar MAP, Zeitronix ZT-2 WB, FRPP 70mm TB, modified UPR CAI, Be Cool Aluminum Rad
toyman is offline  
post #3 of 5 Old 06-30-2015, 09:06 PM
Registered User
 
Trader Feedback: (1)
Join Date: Mar 2014
Location: Charles Town, WV
Posts: 176
Not enough info, what dist are you using? any advance? like vacuum or the spout? total advance should not be more than 34. at idle if the timing is to far retarded, it will run hot, but 180 is not hot. If you have a dist with only mechanical advance then 15 -17 degrees at idle is good, but this also depends on the dist set up, and what total advance is. See what I mean, not enough info.
K8WDX is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 07-03-2015, 01:44 AM
Registered User
 
Trader Feedback: (5)
Join Date: Jun 2012
Location: PA
Posts: 444
14.5 - 15.1 Idle/Cruise is perfectly normal. That's what my A9P did.

I've had factory vehicles wait to turn on cooling fans until 219F (NA Iron block, Alum heads, 10.0 compression, 87 Octane)...so the temp is fine.

180F in 10 mins is absolutely normal.

Not sure on the timing curve.
bsfguy is offline  
post #5 of 5 Old 07-09-2015, 01:34 PM
Registered User
 
Trader Feedback: (9)
Join Date: May 2002
Location: New Braunfels TX
Posts: 4,477
Nothing wrong with what you're describing. That AFR is perfectly fine. 30 degrees advance is a bit much for idle but probably won't hurt anything. I certainly wouldn't increase it.

'94 GT, White, Cobra hood & bumper cover, '95R wheels
393w, Vic Jr 60cc, XE282HR, Victor 5.8 EFI, 80# injectors, Hooker LT 1 3/4 to 3", Borla proXS
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

T56 w/ AJE xmember, McLeod street twin, MM/Bilstein '03 IRS, JRi Agent47 SLA
Megasquirt
seijirou is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Code 91, and engine wont idle after spinning it with coil disconnected... scld1354 General Mustang Tech 12 06-03-2014 01:09 AM
Timing, advance, distributor, ignition ?'s bolt-on-bandito General Mustang Tech 21 02-11-2014 12:19 PM
erratic idle hot or cold SVOJOE 5.0/5.8 Engine Tech 4 05-26-2011 11:07 PM
Engine will not go into fast idle when started cold, causes? FormerlyBlue88Notch 5.0/5.8 Engine Tech 5 03-10-2011 09:27 AM
Engine Dieseling, Fast Idle when hot! cward8 5.0/5.8 Engine Tech 2 12-20-2001 10:09 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome