Massfloefi/ProMracing help - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 07-12-2014, 03:12 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2014
Location: San Mateo Ca
Posts: 2
Massfloefi/ProMracing help

I have installed a massfloefi system on a 66 Corvette. If I haven't lost you guys yet I was hoping for some help since this system is based on 89-93 mustang system. First off Maassfloefi was helpful at first but now I cannot get them to respond to emails or phone calls so that option is out. At first got numerous codes, Chris at massflo said the engine builder may have fried the A9L. Found a used A9L both where showing a 22 code, sometimes a 95 as well. Replaced the BAP sensor. Massflo ecu still shows the 22 code but I get a 11-all good code from the replacement. The A9L from massflo has a moetes chip. The car has been driven approx 2 miles and has gone through about 8 gallons of gas, so you can probably guess the symptoms. After changing the plugs (twice) and the BAP sensor I pulled out the 02 sensors and as you could guess where black. I have ordered new sensors, changed the oil ( smells like gas ) Sent the Massflo ecu in for repair to be sure I still do not have an ecu problem. The motor is brand new and did on initial start up run fine before the trouble began, do not want to keep dumping oil in the pan ,not very good for break in. Am I missing something?

yogiboobuck is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 07-21-2014, 10:09 AM
Corral Elite Member
 
Michael Plummer's Avatar
 
Trader Feedback: (87)
Join Date: Nov 1999
Location: Brockton, MA. USA
Posts: 5,665
Not sure if your contact information is correct, because they are very good at getting back to their messages. Just leave a message, and they'll call you back by the end of the business day.

508-867-6733 or 336-644-8668


849rwhp and 771rwtq SAE
ProCharger D1 and Snow Performance Water/Methanol
Pro-M Racing EMS
Michael Plummer is offline  
post #3 of 6 Old 07-26-2014, 07:48 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2014
Location: San Mateo Ca
Posts: 2
Quote:
Originally Posted by Michael Plummer View Post
Not sure if your contact information is correct, because they are very good at getting back to their messages. Just leave a message, and they'll call you back by the end of the business day.

508-867-6733 or 336-644-8668
I had spoken with Chris and was corresponding with Email w/Sean copied. They are not responding to emails or phone calls. Very disappointed with them and their system. Chris had admitted that they knew they would have problems with this system. Then explained how great their updated version was while qualifying that this was not a sales pitch. I may have pissed him off when I told him it sure sounded like one. Regardless, they should back up their product and not ignore the customer.
I just need to know why this system is dumping mass amounts of fuel into the engine.
Replaced ,so far, plugs, BAP sensor, O2 sensors. Started it up ,smoked out garage and ran like crap. Pulled brand new plug,, it was black. Motor ran for 15 seconds. Somebody reading this has to have an idea of what the problem may be. Again, any help would be appreciated.
yogiboobuck is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 07-27-2014, 11:32 AM
Registered User
 
Trader Feedback: (24)
Join Date: Sep 2005
Location: kansas city
Posts: 288
When I called a few days ago, there was an automated message that said part of their staff was at an offsite conference for the week. Maybe they were already out of the office when you called?
dashjackson is offline  
post #5 of 6 Old 07-27-2014, 10:31 PM
Corral Elite Member
 
Michael Plummer's Avatar
 
Trader Feedback: (87)
Join Date: Nov 1999
Location: Brockton, MA. USA
Posts: 5,665
Quote:
Originally Posted by yogiboobuck View Post
I had spoken with Chris and was corresponding with Email w/Sean copied. They are not responding to emails or phone calls. Very disappointed with them and their system. .
Not picking sides here but there must be a reason why you had contact with them, and now you don't.

849rwhp and 771rwtq SAE
ProCharger D1 and Snow Performance Water/Methanol
Pro-M Racing EMS

Last edited by Michael Plummer; 07-27-2014 at 10:33 PM.
Michael Plummer is offline  
post #6 of 6 Old 07-28-2014, 06:34 PM
Corral Elite Member
 
Michael Plummer's Avatar
 
Trader Feedback: (87)
Join Date: Nov 1999
Location: Brockton, MA. USA
Posts: 5,665
Spoke to Chris Richards today, and he said call him. He's also said they try to return all calls by the end of the business day. If you don't leave a message they won't return your call. Leave your name, contact number and the nature of your business and they will get back to you. Here's Chris's direct line again....508-867-6733.

849rwhp and 771rwtq SAE
ProCharger D1 and Snow Performance Water/Methanol
Pro-M Racing EMS
Michael Plummer is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome