What Can You Tell Me About My Idle - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-10-2014, 09:47 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2014
Location: Canada
Posts: 1
What Can You Tell Me About My Idle

Replaced the wires, plugs and o2's still idles with a slight popping sound. Cant figure it out. Runs amazingingly smooth wide open throttle, with a perfect cold start but as soon as temp goes to 180 it sounds like this. My mechanic says it's turbulance and is normal ? Just need some good advise.



Strokedcoupe is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-11-2014, 08:16 PM
Registered User
 
Blown88GT's Avatar
 
Trader Feedback: (2)
Join Date: Nov 1999
Location: Palm Beach Gardens, FL
Posts: 3,554
Sounds good to me. Don't know what mods you have.


1988 GT, 57k mi, Orig Owner
ProCharger P600B, FRPP Headers, Flowmaster F2, 3G Alt, Mk8 Fan/DCC, 3.55's, Prog Springs, ST Brace, G/Trac Bar, Subfrms, UCA, LCA, FCA, Tokico 5-ways, C/C Plates, CSA 16x8, Bridgestone RE760 Sport 225/50R16, Megasquirt DIYPNPF60, LC2 WBO2, C&L76mm MAF w/LU47's
Blown88GT is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting without tune or calibrated maf. 89blkmustang Turbochargers 21 07-04-2018 07:47 AM
Crank, No Start Blown88GT MegaSquirt DIYAutotune Systems 34 12-28-2013 12:14 PM
FIXED MY ISSUE!!! 87NotchBack5.0 5.0/5.8 Engine Tech 37 07-17-2013 12:03 PM
Reset the TPS if adjust idle...................... from6to8 94/95 Tech 6 07-23-2012 05:06 PM
Idle issue 1990 5.0 saleen246 5.0/5.8 Engine Tech 20 02-04-2006 12:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome