To lean? Correct injector selection? - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-21-2012, 06:44 PM Thread Starter
Registered User
 
Trader Feedback: (2)
Join Date: Apr 2006
Location: Cape Cod, MA
Posts: 59
To lean? Correct injector selection?

I am scheduled to get my fox body tuned. It has a base tune SCT chip in it now and going for the actual dyno tune in 6 days. I am having questions about my fuel setup.

Fuel system: walbro 255 fuel pump, 24lb injectors, bbk fuel pressure regulator set at 39psi

Rest of setup: basic bolt on 302 bored to a 306 forged rotating assembly, 9.6:1 compression, edelbrock heads 1.9/1.6, fcam, 1/7 rockers, gt40 intake setup, 70mm TB, 76mm C&L intake w/ 76mm C&L MAF on blue 24lb sample tube, full exhaust (no cats), blah blah blah just your basic slap together bolt on mustang. N/A setup

I installed a wideband today and all looks good part throtlle, idle, etc. 14.5 range except WOT it runs dangerously lean 19.5+ off the range WOT anything above 4000RPM. But like I said part throttle even above 4000RPM is fine its just WOT it goes very lean. The wideband was calibrated correctly free air and it only reads that lean at WOT. Wideband is reading cyl 5-8 only (driver side pipe) and I smoke tested the exhaust for leaks 10psi no leaks.

I think the base tune is way off because there is no way I am running out of injector WOT at 4000RPM. Anything else you guys can think of would cause this?

I have plans to throw a dry 100 shot on this at some point and need this fuel system to be up to par to handle it. Last thing I need is to run out of injector and need bigger AFTER I get it tuned so I am thinking order 30lb injectors and sample tube just in case or should I be fine on 24lb with a dry shot? I am expecting 325+ the way it is after tune and 400+ with the 100 dry shot.

Here is some footage to show wideband reading. I didnt have time to hook up the RPM wire and TPS wire to the box to actually record a log of the pull (log will only show Wideband & TPS vs RPM anyways) so video will have to do for now to show the described problem I am having.

Is it the tune? Maybe the wideband not accurate? Didnt even think car can pull on a 19.5 A/F but ive never done an NA car before.

Discuss

Wideband test - YouTube


87 Ford Mustang 306, H/C/I Numbers coming soon
krkline2gdsm is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
vacuum leak hints, or running lean rockspyder 5.0/5.8 Engine Tech 26 11-15-2011 10:23 PM
wideband says lean but plugs show rich. Also has a miss. Silver86 5.0/5.8 Engine Tech 13 10-12-2011 12:01 PM
OK question about car running lean.. help IISaleenII SVT & DOHC 5 07-10-2011 01:09 AM
Running Lean? chrismtl GT & SOHC 2 06-13-2011 01:12 AM
70+psi of fuel and still running lean, help! 05Musclestang 5.0/5.8 Engine Tech 17 05-24-2011 01:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome