87 MAF conversion no good without 89 harness? - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-16-2012, 01:39 AM Thread Starter
Registered User
 
Trader Feedback: (1)
Join Date: Aug 2012
Location: Colorado
Posts: 228
87 MAF conversion no good without 89 harness?

Just what the title says. 1987 AOD 5.0, previously converted to T-5. Did an interactive systems and technology MAF conversion including the VSS and FPM2 wires. I think I installed it all correctly. Havnt driven it, and cant for awhile, but it idles and revs fine, no surging or anything. When researching the MAF conversion, I came across this:

https://forums.corral.net/forums/gene...fferences.html

So, for quite awhile, I was concerned I was going to fry my new A9L ECM if I tried to start it with the original 87 speed density auto oxygen sensor harness. So I found a 5 spd 89 O2 harness and was ready to install it. Anyone familiar with this issue will know, that what makes the oxygen sensor harnesses different is just a simple little loop on one plug. On maf car, this "loop" completes and returns a circuit (beyond my understandign really). In SD cars, there are fewer wires on the plug that connects to the oxygens sensor harness. So, I contacted a longtime and respected board member here asking his opinion. Paraphrasing him, he said not to even bother trying to do an MAF conversion using the SD harness, to get an 89 MAF harness and just plug it in. He went on to say that it will just run in limp mode without swapping to an 89 harness. again...paraphrasing. So, that kind of threw me for a loop/ People have been doing MAF conversions adding the pigtail changing some pins aroudn for nearly 20 years. Yes, I understand if done INCORRECTLY it will run in limp mode, but he seemed to be saying you cannot convert an 87-88 to mass air without upgrading to an 89 harness.

Below is the question and answer. Any comments on this anyone?

First off i know you dont want to hear this but the 87 speed density harness your trying to convert wont work. You are right when you said it doesnt have the proper plumbing for that loop signal return which will cause havoc on the mass air car and not have an 02 signal at all. Which equals limbo mode. Car will still run but will be rich and run very slow. Because its in safe mode. Metaphorically ever see a desktop computer run fast and efficient in "safemode" when it boots up? thats what your computer would be doing. Safe mode.

Do yourself a favor if you can. Get rid of the "conversion" kit you spent money on. Get an 89 mass air harness OR you other option is to find an 88 speed density harness that has already the proper plumbing to convert to mass air and use the kit you have. 88 was the first year they made mass air in california only so most of those harness's already came equipped with the proper plumbing to convert to mass air regardless if it was speed density or not.

As for the 02 harness thats easy one. If you dont have the proper looped wire for mass air after you fix the problem with the engine harness then make your own! Basically head to the bone yard and find an old ford EFi dont matter what it is. Cut the 02 cannon plug out (or take the whole thing) cut 2 wires out of the cannon plug back about 2 inches and unclip them from the cannon plug itself. Solder the 2 cut wires together and clip them into the proper locations needed for 5 speed 02 mass air harness. Which in your case would be the far right top and bottom (or number 1 and number 5 location if you numbered it top and bottom left to right staring at the pins. You already know those pins will "click" right into place because it used the same plug on all fords. All that matters here is the loop wire. The other 5 wires found in 2-4 and 7 & 8 locations on that very plug are all the same mass air or speed density.

As for the dash loop its easy to find. Its near the radio on the dash frame. It should have a red and green stripped wire looped in a 2 wire plug. Thats the pedal position switch that tells the computer where the clutch position is when you press and depress. I have seen people run w/o it no problems but why not hook it up as if it were stock right?


Quote:
Originally Posted by 1983Ttop5.0
Alright, I'm fairly new to the forum, but I've read alot of your post in the threads, and can tell you are knowledgable, and have good advice. I'm not new to mustangs, just new to this in depth of knowledge needed for what I'm doing. I'll give you the short version of what I'm doing. 1983 T-top car, factory 5.0 & T-5. Installed a 1990 roller cam engine. Used a wrecked donor 1987 (5.0 AOD) and transplanted ALL chassis, engine and dash wiring, harnesses, interior, etc. Swapped in a manual trans harness. Car ran good temporarily as speed density. I immediatly proceeded on MAF conversion. MAF conversion is all wired in including FPM2 and VSS. Using A9L computer. I've known about the O2 sensor harness issue for months. Theres a few issues that have come up though. Speed density cars have a very basic O2 harness, and do not have that loop (at all) for the signal return. Whats more, on the ECU side that plugs into the O2 harness, even if the O2 harness had the jumper/loop, there are no pins in the factory SD harness for it to connect to. From what I understand, that signal was routed elsewhere in speed density cars. Where? And how do I deal with this? I have checked for voltage at pin 46 while cranking and get less than a volt (.3), so negligible. But.....the sensor that goes on the top of the T-5 trans, is missing (was removed while car was carbed), and I dont know if that can affect any of this. I need to know what I need to do to make it "safe" to plug in my A9L without fear of frying it. Help! Next....I understand there is a jumper in some kind of plug under the drivers side of the dash I need to unplug that was jumpered whiel the car was AOD? How do I identify it/where exactly? Next, what plugs get plugged in at the pedals? If you can help with any of this, man you'd save me a bunch of stress and headaches! Thanks!

1983Ttop5.0 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
1987, 1989, harness, limp mode, maf conversion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale WIring harness conversion for a pushrod motor in a 96-04 S351R"Animal" Electronics and Entertainment 6 12-13-2012 04:26 PM
maf conversion help 5.0boi 5.0/5.8 Engine Tech 10 04-25-2012 12:40 PM
Maf harness g3mustang 5.0/5.8 Engine Tech 6 04-23-2012 11:58 AM
help me id this MAF harness please throthaduece85 General Mustang Tech 7 10-28-2011 11:05 PM
For Sale 91 maf wiring harness & engine harness boosted92 Miscellaneous Mustang Parts 0 11-30-2010 09:08 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome