No Blink 'n Fog - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-13-2002, 04:15 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Dec 2000
Posts: 2
No Blink 'n Fog

Got a 95 GT (See sig)

Prob #1: Turn signals.
The right turn signal works just fine when you hold it in the "Lane Change" position, so I kow the wiring and bulbs are Ok; But when I lock it on I get rear light only in that fast flash that usually tells you you got a bulb burned out.

I suspect I have a dirty contacts problem in the switch itself. Anyone know the way (non-destructive, of course) in there to see if that's true? (And mebbe spritz a li'l contact cleaner on the works?

Prob. #2: Fog Lites.
Right fog light went south. Took the bulb number supplied in the owner's manual to Kragen. Didn't get me anything but a 1000-mile stare from the kid there.

Anybody got a "Real P/N" for those bulbs handy?

fredkc is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-14-2002, 10:06 AM
 
Trader Feedback: (0)
Join Date: Nov 2001
Posts: 713
#1) this might definitly be a bad bulb. I would go grab one from the parts store, and just swap it for the front and/or back and the problem should clear up. The bulb can still work, AND be bad at the same time. I Had that happen to a car I once owned. Same thing.. fast blink, but the bulb was still working. Swapped out the rear right bulb for a new one.. and vuala...

#2) I actually just bought one last week, still havn't put it in yet, I Have the package sitting on a shelf in my garage. When I get home... ill check it out and post the PN

BigPimpHustler is offline  
post #3 of 4 Old 03-14-2002, 10:11 AM
Registered User
 
Trader Feedback: (0)
Join Date: May 2001
Location: BrewCity, WI
Posts: 1,168
Re: No Blink 'n Fog

Quote:
Originally posted by fredkc
Anybody got a "Real P/N" for those bulbs handy?
I usually buy a 893 fog light bulb.
mgranzow is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 03-14-2002, 10:48 AM
Registered User
 
erik_94COBRA's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2000
Location: Brazoria, TX (houston area)
Posts: 591
I buy all of my bulbs at Wal-mart. They should have all of them.

If your problem turns out not to be a bulb, check the two grounds that are near the battery. I was having some problems with the way my indicators worked and one of the grounds (there are two, bolted to the core support) was undone.

Erik
'94 Cobra #2182
erik_94COBRA is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome