Brake lights go off at 1/2 pedal down - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 10-28-2018, 04:05 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Jan 2015
Location: Wichita falls, Tx
Posts: 3
Brake lights go off at 1/2 pedal down

I'm rebuilding and 84 foxbody I've converted to sn95 brakes. With a 95 master and booster. The issue I'm having is the brake lights come on when you press the pedal but when you press more than halfway down they shut off. Any ideas it's a new switch also

Ekim is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 10-28-2018, 04:58 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
the switch is normally closed

therefore without the pedal in the fully up position, the lights will come on

once you step on the pedal the switch closes, it cannot open unless there is an issue with the switch

i would remove the switch and test it


89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #3 of 6 Old 10-28-2018, 05:53 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Jan 2015
Location: Wichita falls, Tx
Posts: 3
The lights work normally. Off when not pressing the pedal and on when you are. The problem is they go off after you press the pedal down more than halfway.
Ekim is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 10-28-2018, 07:14 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
did you not read my post

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #5 of 6 Old 10-30-2018, 04:26 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Jan 2015
Location: Wichita falls, Tx
Posts: 3
I did I test the switch and it functions as should. I went and bough a 94/95 switch. Which is slightly different than the fox one. And now they work fine
Ekim is offline  
post #6 of 6 Old 10-30-2018, 07:16 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
You were using wrong parts?

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rdrcrís 2013 Mustang GT Upgrades and Reviews Thread. Rdrcr S-197 Mustang GT (2011-2014) 62 12-11-2014 12:36 PM
brake troubles, very hard pedal spic21 General Mustang Tech 12 06-10-2013 01:10 PM
For Sale Hawk Brake Pads FREE SHIPPING [email protected] Suspension 6 12-02-2011 12:35 PM
Brake pedal switch installation/wiring eggens Electrical & Wiring 2 06-11-2011 03:55 PM
1995 mustang gt brake light issue PLEASE help fgustin 94/95 Tech 2 04-07-2011 03:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome