88 5.0 won't start - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 08-23-2018, 09:02 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Dec 2015
Posts: 12
Garage
88 5.0 won't start

Having a no start issue with my 88 5.0. I put the key in and I get the normal "door open key in ignition" tone dome light on everything normal. Turn the key to accessory and everything still normal. As soon as I turn past accessory into "run" I loose almost all power. Door tone stops, dome light out, gauges dead. Only a slight noise from the back that sound like my fuel pump but weak. I have clean terminals and a good battery. I have already replaced the ignition switch also. I am not an electrician. This issues happened suddenly and without warning. Been a clean good running car for years.

Hot88 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 08-23-2018, 09:19 PM
Registered User
 
Trader Feedback: (21)
Join Date: Sep 2015
Location: Midwestern Illinois
Posts: 1,331
That sounds like a poor ground somewhere.


For everything that is worthwhile, there is a counterfeit.
boostup89 is online now  
post #3 of 6 Old 08-23-2018, 10:30 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
why did you replace the switch?

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 08-24-2018, 08:38 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Dec 2015
Posts: 12
Garage
As I said the car does not start. I have very limited diagnostic ability but I knew the ignition switch is a common problem in these cars and I thought it could have been causing those symptoms therefor replaced.
Hot88 is offline  
post #5 of 6 Old 08-24-2018, 07:35 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
cause it doesn't start, does not mean you cannot test the switch

use a test light to batt neg

and probe across the switch in the various positions, the light will come on when the switch is working

you only need to know which pins to test at each position

they sell wiring diagrams, sometimes for free, so that you can id them

infact you don't need them, if you understand the design....regardless, its easy to test

so lets assume your NEW switch is faulty

test it.

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #6 of 6 Old 08-25-2018, 05:13 PM
Registered User
 
Blown88GT's Avatar
 
Trader Feedback: (2)
Join Date: Nov 1999
Location: Palm Beach Gardens, FL
Posts: 3,552
If you replaced the ignition switch, you are an electrician, of sorts.
Your good running car is 30 years old.
Maybe battery terminals are clean, but cable clamps not tight enough.

1988 GT, 57k mi, Orig Owner
ProCharger P600B, FRPP Headers, Flowmaster F2, 3G Alt, Mk8 Fan/DCC, 3.55's, Prog Springs, ST Brace, G/Trac Bar, Subfrms, UCA, LCA, FCA, Tokico 5-ways, C/C Plates, CSA 16x8, Bridgestone RE760 Sport 225/50R16, Megasquirt DIYPNPF60, LC2 WBO2, C&L76mm MAF w/LU47's
Blown88GT is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Car Rarity? preppypyro General Mustang Tech 8 04-13-2016 01:14 PM
code 66 and 98 but i have no Maf keyl0ger General Mustang Tech 15 05-07-2014 07:58 PM
88 5.0 Mark VII LSC Cranks wont start White88LSC 5.0/5.8 Engine Tech 11 09-12-2013 02:37 PM
5.0 as a donor motor... start with Explorer or Mustang? taiden 5.0/5.8 Engine Tech 5 05-22-2011 07:26 PM
5.0 Mustang vs LS2 Vette vs LS3 Vette 00whiteGTvert S-197 Mustang GT (2011-2014) 41 01-21-2011 09:08 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome