Bad ECM? - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 08-06-2018, 10:25 PM Thread Starter
Registered User
 
Trader Feedback: (13)
Join Date: Dec 2007
Location: Columbus, OH
Posts: 149
Bad ECM?

I have an '88 that I believe has a bad ECM, but I wanted to get feedback on this before I make any plans to buy another A9P for my car.

When you turn my car's key to the ignition position, the fuel pump doesn't energize. The inertia switch has power going through it, so I know that it's not tripped and is working properly. 12v power is being supplied to both the power and control circuits of the fuel pump relay. I verified that the ground wire for the power circuit is properly grounded, but the driver circuit in the ECM doesn't seem to be grounding the control circuit for the fuel pump relay and I'll tell you why. With the key in the ignition position, the fuel pump will energize and run if you connect the tail of a circuit tester to ground and then probe the ground terminal of the control circuit, on the fuel pump relay. By probing that terminal, with the circuit tester, you're grounding the control circuit, instead of the ECM driver circuit doing it, like it should be. To be thorough, I checked the continuity of the wire that runs from the control circuit ground terminal on the fuel pump relay to the driver circuit of the ECM and the wire did have good continuity.

When you consider everything I just shared with you, I can't see how the problem could be anything but a bad driver circuit in my A9P ECM. I just wanted to bounce this off of you guys to make sure I'm correct in my thoughts about what the problem really is here.

Any feedback on this would be appreciated!

LeaningMachine is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 08-07-2018, 09:16 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,253
throw the continuity test out the window, its useless

perform a voltage test at the ecm on the ground switch

lets just say the ground is good

what would prevent, other than a failed ecm, the driver from grounding?

better, what are the conditions needed for it to ground?

knowing that, you can test correctly,,,,you might be missing something???


89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #3 of 9 Old 08-08-2018, 11:37 PM Thread Starter
Registered User
 
Trader Feedback: (13)
Join Date: Dec 2007
Location: Columbus, OH
Posts: 149
Well, crap! The driver circuit in the ECM was bad. Thanks for your help with figuring this out, Indy.
LeaningMachine is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 08-09-2018, 12:19 AM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,253
part swap?

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #5 of 9 Old 08-09-2018, 08:07 AM
Registered User
 
Nitrous Al's Avatar
 
Trader Feedback: (2)
Join Date: Jun 2003
Location: Massachusetts
Posts: 1,542
Question

Is there a shop or someone that specializes in checking ECMs? I'm going to be putting my A9P in with the HCI swap soon.

'88 5.0 GT hatch AOD 3.08
stock 302, Ed Curtis cam & 11R 190 heads,
Holley SM2, 320 hp 332 tq to the wheels
Nitrous Al is offline  
post #6 of 9 Old 08-09-2018, 05:47 PM
Registered User
 
Blown88GT's Avatar
 
Trader Feedback: (2)
Join Date: Nov 1999
Location: Palm Beach Gardens, FL
Posts: 3,552
Check your local AutoZone. You can still get remans with or without a core exchange, about $100 w/exchange.

1988 GT, 57k mi, Orig Owner
ProCharger P600B, FRPP Headers, Flowmaster F2, 3G Alt, Mk8 Fan/DCC, 3.55's, Prog Springs, ST Brace, G/Trac Bar, Subfrms, UCA, LCA, FCA, Tokico 5-ways, C/C Plates, CSA 16x8, Bridgestone RE760 Sport 225/50R16, Megasquirt DIYPNPF60, LC2 WBO2, C&L76mm MAF w/LU47's
Blown88GT is offline  
post #7 of 9 Old 08-10-2018, 12:00 PM Thread Starter
Registered User
 
Trader Feedback: (13)
Join Date: Dec 2007
Location: Columbus, OH
Posts: 149
No. I have a kill switch installed right before where the ground wire for the control circuit enters the ECM. I was getting good power through that switch, but the circuit wasn't grounding, so I grounded the circuit right before where the wire entered the ECM. When I did that, the fuel pump energized and worked as it should. That told me that the driver circuit in the ECM wasn't grounding the circuit like it was supposed to, verifying for me that the problem was, in fact, the driver circuit in the ECM, as I feared.
LeaningMachine is offline  
post #8 of 9 Old 08-10-2018, 02:48 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,253
did you verify the input that tells the ecm to energize the driver?

the ecm only grounds that when it has the proper inputs

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #9 of 9 Old 10-13-2018, 03:12 AM
Registered User
 
EvilGooses's Avatar
 
Trader Feedback: (7)
Join Date: Aug 2004
Location: Minnesota
Posts: 675
Quote:
Originally Posted by Blown88GT View Post
Check your local AutoZone. You can still get remans with or without a core exchange, about $100 w/exchange.
Not available anymore. They also seem to think there is a 50$ price difference between A9Ls of different years
EvilGooses is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting without tune or calibrated maf. 89blkmustang Turbochargers 21 07-04-2018 07:47 AM
junkyard ecm wont reflash with new vin n0spony1 GT & SOHC 23 02-01-2016 07:35 AM
1993 Cobra w/SSP ECM Cobra18 Engine Management Systems 2 10-22-2013 12:03 AM
Need help picking an Auto ECM for my Cobra Build Owenslee SVT & DOHC 3 09-13-2013 04:12 PM
MSD crap or did i just get some bad stuff? venom95svt 94/95 Tech 3 01-30-2003 11:49 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome