Blowing fuses 1993 Mustang - Ford Mustang Forums : Corral.net Mustang Forum
 1Likes
  • 1 Post By fox88
 
LinkBack Thread Tools Display Modes
post #1 of 17 Old 09-04-2017, 06:04 PM Thread Starter
Registered User
 
TK1299's Avatar
 
Trader Feedback: (4)
Join Date: Mar 2016
Location: Houston TX
Posts: 130
Blowing fuses 1993 Mustang

To start, I have googled and googled and still haven't really found anything that has helped me solve my issue. There are tons of posts on this topic and I hate to start another, but I need help.

I was recently driving my 1993 Mustang and noticed the turn signals no workie. I checked the fuse and sure enough it was blown. I've since inserted six fuses and they all blow immediately when I turn the ignition to accessory.

I did within the past week change out all of the lenses on the front lights, but kept all the bulbs. Everything worked fine over the weekend, and I drove it quite a bit.

I removed the lenses and checked the wiring to the turn signals and traced it as far as I could and found no place where a problem could be.
The turn signal lamps work when the emergency flashers are on and when the lights are turned on.

Clearly it's electrical someplace, I am hoping someone in here has experience with this and can point me in a better direction. At this point I'm just staring at all the wires I can see and hoping a blind squirrel finds a nut.


1993 Cobra: KB 2.1 Flowzilla, Alkycontrol meth injection
2003 Cobra: K&N / Borla Exhaust
TK1299 is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 09-05-2017, 12:00 AM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
when a fuse blows, you don't need to replace it

the circuit does NOT fix itself

Do you have a incad test light?

do not put another fuse in, unless you like watching them blow.


89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #3 of 17 Old 09-05-2017, 05:53 AM Thread Starter
Registered User
 
TK1299's Avatar
 
Trader Feedback: (4)
Join Date: Mar 2016
Location: Houston TX
Posts: 130
I jiggled wires and re-covered them and would insert another fuse hoping it would fix. I have an electrical test light, yes. I'm not sure how to test the circuits or even where.

1993 Cobra: KB 2.1 Flowzilla, Alkycontrol meth injection
2003 Cobra: K&N / Borla Exhaust
TK1299 is offline  
Sponsored Links
Advertisement
 
post #4 of 17 Old 09-05-2017, 08:14 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
so the fuse only blows in acces position?

not in run or crank?

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #5 of 17 Old 09-05-2017, 10:03 PM Thread Starter
Registered User
 
TK1299's Avatar
 
Trader Feedback: (4)
Join Date: Mar 2016
Location: Houston TX
Posts: 130
It blows as soon as I turn the key on, before the car cranks. It's the #5 fuse which controls the turn signals, reverse lights, rear window defroster and low fluid light. I am wondering if I remove the bulbs and one by one put them back in if I can isolate where the trouble spot is? I have almost zero experience with electrical.

1993 Cobra: KB 2.1 Flowzilla, Alkycontrol meth injection
2003 Cobra: K&N / Borla Exhaust
TK1299 is offline  
post #6 of 17 Old 09-05-2017, 10:43 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
okay

the ignition switch has

Acces


Run

Crank

which one are you referring to??

it matters, so be accurate.

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #7 of 17 Old 09-06-2017, 01:10 PM Thread Starter
Registered User
 
TK1299's Avatar
 
Trader Feedback: (4)
Join Date: Mar 2016
Location: Houston TX
Posts: 130
It blows it when I turn the key to accessory.

1993 Cobra: KB 2.1 Flowzilla, Alkycontrol meth injection
2003 Cobra: K&N / Borla Exhaust
TK1299 is offline  
post #8 of 17 Old 09-06-2017, 04:22 PM
Registered User
 
fox88's Avatar
 
Trader Feedback: (20)
Join Date: Jul 2012
Location: Pa
Posts: 4,895
Garage
First thing I would do, if you brought that car to me, is this. It's easy enough to disconnect everything that circuit powers up. Put the fuse back in and turn key on. Should be good. Start connecting things back up until you isolate the problem. Simple enough.

If you recently changed out lenses, and didn't have the issue beforehand, that seems like a logical place to start.

And of course, the obvious. I always do this first whenever I purchase a used car. Check every fuse. Be sure it's the amperage Henry says it should be, and not something smaller. I was just working on something a week ago, where I found someone replaced all the 15a fuses with 30's, lol.

Not good, for obvious reasons.
tony91723 likes this.

FTI TW heads/FTI cam/RPMII/A-trim/T5 & 4.10's/QH w/ BE & EA/GUFB
www.carstereooneinc.com
fox88 is offline  
post #9 of 17 Old 09-06-2017, 05:57 PM Thread Starter
Registered User
 
TK1299's Avatar
 
Trader Feedback: (4)
Join Date: Mar 2016
Location: Houston TX
Posts: 130
Thanks man. I just got home from work and headed to the garage to try that.

1993 Cobra: KB 2.1 Flowzilla, Alkycontrol meth injection
2003 Cobra: K&N / Borla Exhaust
TK1299 is offline  
post #10 of 17 Old 09-06-2017, 07:17 PM Thread Starter
Registered User
 
TK1299's Avatar
 
Trader Feedback: (4)
Join Date: Mar 2016
Location: Houston TX
Posts: 130
I removed the front signal bulbs and inserted a new fuse. I turned the car to accessory and turned on both signals. Each illuminated,but obviously didn't blink since the front bulbs were missing. I then started the car and the fuse blew immediately. I inserted another fuse, with the bulbs still removed, and turned the ignition to accessory again which immediately blew the fuse again. Fml


1993 Cobra: KB 2.1 Flowzilla, Alkycontrol meth injection
2003 Cobra: K&N / Borla Exhaust
TK1299 is offline  
post #11 of 17 Old 09-07-2017, 08:26 AM
Registered User
 
fox88's Avatar
 
Trader Feedback: (20)
Join Date: Jul 2012
Location: Pa
Posts: 4,895
Garage
Pull your column apart also, and check out the condition of this little guy. https://lmr.com/item/LRS-11572A/79-9...gnition-Switch

A very common problem on the Fox Mustangs. Mine went bad on me once. And when it did, I didn't have any turn signals or reverse lights. Might be on that same circuit. I have all the OEM Ford manuals, just not in front of me to look. But you can pick those up at any local auto parts retailer.

Just something else quick and easy to check.

FTI TW heads/FTI cam/RPMII/A-trim/T5 & 4.10's/QH w/ BE & EA/GUFB
www.carstereooneinc.com
fox88 is offline  
post #12 of 17 Old 09-07-2017, 03:48 PM Thread Starter
Registered User
 
TK1299's Avatar
 
Trader Feedback: (4)
Join Date: Mar 2016
Location: Houston TX
Posts: 130
Ok I'll trouble shoot that. Thanks man

1993 Cobra: KB 2.1 Flowzilla, Alkycontrol meth injection
2003 Cobra: K&N / Borla Exhaust
TK1299 is offline  
post #13 of 17 Old 09-07-2017, 05:32 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
With no fuse in

Connect the test light to battery pos

Then the test light to the load side of the fuse

Use a blade of some sort to keep the test light attached to the load side of the fuse

This will be your fuse

Then repeat what you did with the ign switch

If the test light is bright, you can measure with a dvom the actul voltage, you have a short to ground

With the test light attached you are going to unplug parts of the circuits untill when the test light goes dim or out

The last thing you unplug has the short

This is very easy to do if you know what to look for

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #14 of 17 Old 09-07-2017, 06:59 PM Thread Starter
Registered User
 
TK1299's Avatar
 
Trader Feedback: (4)
Join Date: Mar 2016
Location: Houston TX
Posts: 130
Thanks Indy. I removed the column cover and under the dash and checked all that. It all appeared new and in good shape, as did the ignition switch. I checked as many wires as I could find under hood and still no luck. I hate to admit defeat but I may take it to a shop tomorrow and see if they can diagnose it.

1993 Cobra: KB 2.1 Flowzilla, Alkycontrol meth injection
2003 Cobra: K&N / Borla Exhaust
TK1299 is offline  
post #15 of 17 Old 09-07-2017, 07:51 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
its easy

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #16 of 17 Old 09-07-2017, 09:28 PM Thread Starter
Registered User
 
TK1299's Avatar
 
Trader Feedback: (4)
Join Date: Mar 2016
Location: Houston TX
Posts: 130
I researched an ECT2000 power probe. Might be a worthy investment

1993 Cobra: KB 2.1 Flowzilla, Alkycontrol meth injection
2003 Cobra: K&N / Borla Exhaust
TK1299 is offline  
post #17 of 17 Old 09-07-2017, 09:38 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
not needed

but if it helps

go for it

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale 1993 Mustang LX Coupe Reef Blue Dogman_1969 Mustangs For Sale/Wanted, 1987-1993 5 08-07-2017 03:10 PM
American Traditions, Hot Rods, and Horses; 2013 Mustang review and roadtrip story stevegolf Lounge 0 11-18-2013 09:21 AM
My Mustang Videos mike06tr Video 3 10-05-2011 03:00 PM
For Sale LARGE Lot of NOS and USED 5.0 93 - 87 Mustang Cobra parts mach3514v Exterior Parts 0 06-23-2011 08:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome