A9L reading constant 150 coolant temp with good sensor - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-29-2017, 07:57 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Jul 2015
Location: Cleveland,Oh
Posts: 27
A9L reading constant 150 coolant temp with good sensor

just like the title says.. I have a 90 foxbody with h/c/i and I cant tune the damn thing because the computer is constantly seeing 150 degree engine temp. I know this is the default setting for a faulty coolant temp switch, but I have verified that the switch is not faulty with an ohm meter.

Any ideas?

its a 306 with 11r 190s, tf stage 2 cam, street heat intake, 30lb injectors, long tubes, egr delete.. tuning with a quarter horse. Had it running good when hooked to the quarter horse, burnt a chip and it runs rich and wont idle for crap.

SweetNLow is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-30-2017, 08:44 PM
Registered User
 
TomR's Avatar
 
Trader Feedback: (2)
Join Date: Aug 2009
Location: Macon, GA
Posts: 4,947
Garage
The sensor is not a switch. It is a variable resistor called a "thermistor".

This is the sensor you should have. Note the resistance given in the text for various temperatures:

Attached Images
File Type: jpg ECT sensor1.jpg (192.2 KB, 13 views)


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
89 LX. 363, single turbo, Super Vic EFI, TFS high port heads by TEA, solid roller, glide. Holley HP EFI. (exact combo varies)
TomR is offline  
post #3 of 3 Old 06-06-2017, 02:46 PM
Registered User
 
theYman's Avatar
 
Trader Feedback: (25)
Join Date: Nov 2013
Location: Medina Ohio
Posts: 887
I would back probe the salt n pepper connectors . Possibly a broken wire somewhere.

347 Stroker/ TW170 heads /TrickFlow R intake/ FordStroker cam/Longtubes Astro A5
The thick CLOUD of tire smoke ,the SMELL of burning rubber,and the CHEER of the crowd ....PRICELESS.
$90.00 fine for an awesome burn-out,worth every penny...
theYman is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting without tune or calibrated maf. 89blkmustang Turbochargers 21 07-04-2018 07:47 AM
Best Wideband 02 out there? bunso Electrical & Wiring 14 01-17-2014 01:16 AM
Man facing jailtime for owing child support commits suicide on courthouse steps MurPHy4570 Politics 96 02-19-2012 01:24 PM
What Coolant/Antifreeze Do You Use? BTJustice GT & SOHC 13 12-26-2011 06:25 PM
coolant temp sensor herbiehind 5.0/5.8 Engine Tech 4 07-02-2011 02:59 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome