headlights not working - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 05-06-2017, 09:23 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Jan 2017
Posts: 18
headlights not working

my headlights were working just fine but now they're not after doing a header swap. I have an 89, checked the switch wiring and everything seems fine, my parking lights work, dash lights up, flash to pass works, but no headlights on low or high. I did drop the steering column to remove the steering shaft and ragjoint, reinstall was a pain having to jerk the steering wheel back out so I'm not sure if I pulled off a ground or accidentally unhooked something.... any help is much appreciated

Josey is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 05-07-2017, 01:52 AM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
pins not seated

if that is not it, most likely MFS

is this a GT?


89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #3 of 5 Old 05-07-2017, 06:02 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Jan 2017
Posts: 18
Quote:
Originally Posted by indy2000 View Post
pins not seated

if that is not it, most likely MFS

is this a GT?
no 89 LX Hatch, I tried seating the pins in the switch and didn't seem to do anything, are the pins in the MFS prone to coming loose too?
Josey is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 05-07-2017, 06:49 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
yes out of the connectors

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #5 of 5 Old 05-08-2017, 05:47 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Jan 2017
Posts: 18
Quote:
Originally Posted by indy2000 View Post
yes out of the connectors
You got it right Indy, I messed around with the MFS pins and everything works as it should now, except for the dome and mirror lights, still have no idea what is wrong with them
Josey is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mustang GT HID headlights on Mustang V6 Pony Package High Beam not working rob1234 Electrical & Wiring 1 03-09-2016 09:29 AM
The most eye-catching headlights you've ever seen! carid CARiD.com 0 01-06-2016 04:45 AM
Tach not working (98 GT)....or randomly working lunatic GT & SOHC 1 04-29-2015 07:33 AM
Something wrong with headlights SmokeyDP General Mustang Tech 3 12-12-2001 05:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome