Water Reservior Sensor Short - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-06-2017, 09:23 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2017
Posts: 4
Question Water Reservior Sensor Short

Working on a 1993 Mustang LX 5.0 with Low Coolant light on. Replaced the cap and sensor assembly, light went off for short period of time and came back. Sensor now appears to be shorted. Bought another one, checked voltage on plug from car, red with yellow stripe showing 12 volt and blue wire showing 12 volt also. Any idea on what they should be?

Dstanley is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-06-2017, 10:50 AM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,262
the R/Y is powered from fuse 18

LB is also powered from fuse 18, but it goes through the low coolant bulb

that means the R/Y going to the coolant module is powering the sensor

when the LB gets pulled to ground through the sensor the bulb will go on.

you can bench test the sensor with a test light and battery power in a bucket of water.


89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #3 of 4 Old 05-06-2017, 05:31 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2017
Posts: 4
Appreciate the info. I thought putting a new one on that it might have been bad but bought another and did the same thing. Something crazy going on. I put a jumper wire on the contacts posts and ohmed the r/y and b and had ohmes. figured that would mean it was right.
Dstanley is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 05-06-2017, 07:45 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,262
bench test it

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Water in exhaust tried alot of things portland or shawnhigh 5.0/5.8 Engine Tech 2 07-13-2015 03:52 AM
For Sale Complete SBF Remote Water Pump Setup! Meziere Pump / Fragola Fittings! *NEW* swapped5.0 Windsor Engine Parts 6 07-06-2015 09:49 PM
water pump rotation and A/C delete, need a pulley or idler? thedarko General Mustang Tech 4 08-27-2014 03:39 PM
Found this threaded metal piece in my water pump today putertopia 94/95 Tech 6 04-05-2014 01:59 AM
standard / reverse rotation water pumps ? nick5oh 5.0/5.8 Engine Tech 20 10-13-2011 10:58 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome