Left door speaker not working. - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 11-20-2016, 01:08 PM Thread Starter
Registered User
 
JacobV1997's Avatar
 
Trader Feedback: (7)
Join Date: May 2016
Location: San Antonio, TX
Posts: 227
Left door speaker not working.

I pulled my dash out of the car and painted everything, put the dash back together and now the left door speaker is not working. I did add a tachometer and oil pressure gauge and I tapped into speaker wires to power them, but the speaker doesn't work with them plugged in or not. Also did some welding to my floor pans near the factory amplifier under the passenger seat, but the connectors and terminals all look fine and clean.

I am very mechanical inclined, build engines for a living, but I am a complete novice when it comes to electrical work. I have checked all my connectors and radio settings, everything is plugged in, yet the left door speaker no longer has any movement or sound.

Any ideas?


1993 Mustang GT
436.8hp/391.5tq 10.1:1 306", GT40p Heads, Victor Jr/750, Scott Brown Cam.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JacobV1997 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-21-2016, 09:15 AM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,262
how do you mean you tapped into the speaker wire?

like as a 12 volt source for power and ground?


89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
'90 5.0: Blinkers and high beams not working...? Bullitt5253 General Mustang Tech 10 07-07-2012 09:03 PM
O2's not working properly saleenboy87146 5.0/5.8 Engine Tech 10 04-11-2012 07:43 PM
Hopefully the rain stops at Dover,,any other Nascar fans??? NJ5pnt0 Lounge 33 05-18-2011 09:57 PM
Ok thouroughly confused..right front wheel sticks out 2 cm more than left front.. PolishSasquatch General Mustang Tech 5 05-13-2011 02:09 PM
US is Bombing Libya, this is a test of America's Left P63 Politics 13 03-22-2011 09:18 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome