indicator (idiot) lights not working - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-19-2016, 02:24 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Mar 2013
Location: florida
Posts: 99
indicator (idiot) lights not working

I just bought a 93 lx with low miles. I just noticed that none of the indicator lights turn on when I put the key forward. The ebrake light doesn't turn on either when I pull the ebrake. Any ideas? I checked fuses and they all seem to be good.

1987gn is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-21-2016, 12:58 AM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
key in forward?

what is that?
how do you put a key in backward?


89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #3 of 4 Old 09-21-2016, 02:02 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Mar 2013
Location: florida
Posts: 99
^^^^good one
1987gn is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 09-21-2016, 05:46 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
what is good?

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1993 mustang help - no cluster lights and taillights nichols_james08 General Mustang Tech 4 11-17-2014 01:28 AM
93 lx dash lights out pistolero Electrical & Wiring 2 07-09-2011 12:39 AM
turn signal lights not working!!! dimitrios 5.0/5.8 Engine Tech 0 12-17-2001 05:00 PM
No brake lights Rolf General Mustang Tech 4 12-09-2001 10:23 PM
dash lights & taillights not working glad31 General Mustang Tech 12 11-29-2001 04:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome