2004 GT Headlight and turn signals problem - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 07-30-2016, 04:37 AM Thread Starter
Registered User
 
CrucialProspect's Avatar
 
Trader Feedback: (0)
Join Date: Jan 2016
Posts: 915
2004 GT Headlight and turn signals problem

04 GT, I'm not ruling out a hack job on wiring, but there were some wiring modifications prior to me getting the car, the fog lights have been removed, etc. when I pull out the headlight switch, the low beams come on as well as both turn signals, they don't flash, just stay on. If I try to use the signal, nothing, brights do work but same thing. Tail lights have brake lights and the running lights, but no turn signal either. On the instrument cluster it shows exactly what it's doing, lights and both turn signal. Any ideas on where to start?

CrucialProspect is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 08-01-2016, 12:35 AM
Registered User
 
n0spony1's Avatar
 
Trader Feedback: (12)
Join Date: Mar 2002
Location: monroe , nc
Posts: 815
possibly the flasher, I think when the headlights come on the marker lights one the corners will light up.. id check the flasher.. do the hazards work ? I think hazards are on a different flasher but I'm not positive..


93 LX coupe 393 efi, on moth balls.
03 GT 2V [email protected] ..
n0spony1 is offline  
post #3 of 7 Old 08-01-2016, 09:45 PM Thread Starter
Registered User
 
CrucialProspect's Avatar
 
Trader Feedback: (0)
Join Date: Jan 2016
Posts: 915
Hazards work as they should flasher is good as well, I installed a new one and it does the same thing.
CrucialProspect is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 08-03-2016, 05:50 AM Thread Starter
Registered User
 
CrucialProspect's Avatar
 
Trader Feedback: (0)
Join Date: Jan 2016
Posts: 915
Flashed I used was a Novita ep27, it has the same symptoms as the motorcraft, so I returned it. Also, dash chimes fast once the lights are pulled out, I checked all the fuses I thought would be on that circuit.
CrucialProspect is offline  
post #5 of 7 Old 08-05-2016, 02:18 AM
Registered User
 
n0spony1's Avatar
 
Trader Feedback: (12)
Join Date: Mar 2002
Location: monroe , nc
Posts: 815
I believe the hazard has its own flasher and is different than the turn signals.. i'll try to find a fuse box pic to double check .. my expedition had one go bad and no turn signals would work.. before they had stopped the flasher would buzz when it did work.. I would only use a ford flasher.. I would test this and pull the flasher and see what stops working.. if neither work then you know..
its possible you could have a multifunction switch gone bad or something.. you just have to keep trying to narrow it down..

93 LX coupe 393 efi, on moth balls.
03 GT 2V [email protected] ..
n0spony1 is offline  
post #6 of 7 Old 08-05-2016, 04:12 PM Thread Starter
Registered User
 
CrucialProspect's Avatar
 
Trader Feedback: (0)
Join Date: Jan 2016
Posts: 915
Pulling the flasher module kills hazards and flasher, checked all associated fuses, I guess I'll be pulling the column apart to check the wiring coming from the multifunction switch, obviously if I test it inline before the module and get a pulsing signal, I can narrow it down. I just need to find a diagram with wire colors. I'm not 100% on how these systems work, I'm used to the older style that pulses a 12v circuit, not sure if this is the same.
CrucialProspect is offline  
post #7 of 7 Old 08-08-2016, 09:06 PM Thread Starter
Registered User
 
CrucialProspect's Avatar
 
Trader Feedback: (0)
Join Date: Jan 2016
Posts: 915
Did some more tinkering, turn signals work with headlights off, headlights on and nothing.
CrucialProspect is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signal problem Accugroove General Mustang Tech 7 11-13-2015 02:16 PM
Want To Buy Headlight and signal harness for an 88 GT tpoch845 Electronics and Entertainment 0 06-01-2014 10:34 PM
89 gt wire that goes from fuse panel to headlight switch melts HELP whitley Electrical & Wiring 0 11-20-2012 05:53 PM
Strange Fan problem on 00 Gt (has ground, 12v and doesn't move) Mesarina GT & SOHC 10 11-23-2011 04:05 AM
Yet another Fox turn signal problem Kranium31 General Mustang Tech 20 05-28-2011 12:37 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome