No buzz -fuel pump relay ? - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-09-2016, 08:50 PM Thread Starter
Registered User
 
chazmanaz's Avatar
 
Trader Feedback: (0)
Join Date: Jul 2006
Location: PHX
Posts: 32
No buzz -fuel pump relay ?

Usually when I turn the key you hear a buzz, then hit the key and it fires. Some wires got burnt(from the battery), but the car turns over, but no start. I've read some posts about the fuel relay but I don't know where to start to look for that or the ECM? or a fuse. any ideas would be helpful. 1991 5.0lx. thanks


91lx vert-GT40 heads/1.7 rollers/Edelbrock performer intake/BBK headers/Bassani X w/cats MAC catback/3.73 rear/AOD
00 Grand Cherokee-4.7/K&N intake/Dynomax ex/hauls ass
05 G35 fast & comfy
IF YOU DON'T GO---YOU WON'T KNOW
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chazmanaz is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-09-2016, 10:58 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,262
its all in a EVTM wiring diagram for your year.


89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #3 of 4 Old 07-25-2016, 10:58 PM
Registered User
 
foxfan5.0's Avatar
 
Trader Feedback: (1)
Join Date: Jul 2016
Posts: 80
Or someone could just tell you...the fuel pump relay is under the driver seat. I've had fuel issues with 2 foxes so far, one ended up being a bad ground on the pump housing/sending unit...whatever you want to call it. The part that's in the tank. It has a ground on the top of it, where the connector plugs into, then it has another ground on the underside of the top. Mine had corroded the ground on the underside of the top and I had no humming for priming when I turned my key on. So you may need to drop your tank and check that and the connector for it if swapping the relay doesn't work. And then on the second fox, after I checked all that, I came to the conclusion that it was a bad ecm, which is located under the passenger kick panel. If you take it to ford they'll be happy to swap out ecm's for about 400 bucks. Or you could do like I did and buy it from autozone and swap it out during your lunchbreak. It literally took me 20 minutes. Hope this helps.

Nothing feels as good as being thrown back in your seat because of the power you built.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
foxfan5.0 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 07-25-2016, 11:45 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,262
you don't need to drop the tank to find a bad ground..........they make volt meters now.

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
fuel pump wiring headache vlzstallion Electrical & Wiring 11 06-02-2016 11:54 PM
Fuel Pump won't prime Dj_Seph General Mustang Tech 19 09-23-2014 09:41 PM
FUEL PUMP RELAY KEEPS BLOWING(BURNING) mustanglx5.0 Electrical & Wiring 2 06-04-2014 01:07 AM
weird idle '89Vert General Mustang Tech 4 05-27-2014 12:15 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome