1996 Electrical help - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 04-04-2016, 05:23 PM Thread Starter
Registered User
 
B0jangles's Avatar
 
Trader Feedback: (0)
Join Date: Jul 2014
Location: California
Posts: 334
Garage
1996 Electrical help

Checked my fuses because the cigarette lighters in my 96 GT died. The fuse was blown, but I also noticed two empty spaces in the box. Top is supposed to be empty, but the one on the bottom is for the Air Injection system?


The car passed visual and the sniffer with flying colors, but it is a hastily-installed 99 PI. Will these engines pass with the system disabled or did the previous owner jerry rig the relay somewhwere else?

I also get a loud pop sometimes when I start the car with the stereo on, but only if the accessory is on for a few seconds before hitting the starter. I think it's a bad ground, but it only happens after cranking the starter, not when the stereo turns on

Any red flags from you guys? Things to check on? Thanks in advance

B0jangles is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-04-2016, 05:32 PM Thread Starter
Registered User
 
B0jangles's Avatar
 
Trader Feedback: (0)
Join Date: Jul 2014
Location: California
Posts: 334
Garage
Diagram I referenced


http://www.allfordmustangs.com/forum...p-1996-bjb.gif

B0jangles is offline  
post #3 of 6 Old 04-07-2016, 09:52 PM
Registered User
 
Trader Feedback: (1)
Join Date: Oct 2012
Location: Gilbert, AZ
Posts: 83
It does sound a bit like a short he thought he solved by removing the fuse for the air injection system. When I look at the wire diagram I don't see any inputs to the PCM for the air injection system so I'm guessing it won't set a DTC code even if its unplugged. It is only intended to alter conditions at startup and is not necessary after something like 2 minutes. Not sure I helped solve your electrical issue though.
az97cobra is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 04-07-2016, 11:26 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,253
put a test light to batt pos, and probe both pins.

if there is a short to ground, it will light up

then go find it.

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #5 of 6 Old 04-08-2016, 03:44 AM Thread Starter
Registered User
 
B0jangles's Avatar
 
Trader Feedback: (0)
Join Date: Jul 2014
Location: California
Posts: 334
Garage
Quote:
Originally Posted by az97cobra View Post
It does sound a bit like a short he thought he solved by removing the fuse for the air injection system. When I look at the wire diagram I don't see any inputs to the PCM for the air injection system so I'm guessing it won't set a DTC code even if its unplugged. It is only intended to alter conditions at startup and is not necessary after something like 2 minutes. Not sure I helped solve your electrical issue though.
Interesting they didn't wire an emissions system to the computer. I have noticed the car puts out a good ammount of water vapor for a while when I warm it up in the mornings. I assumed 90s v8, but it makes sense the 6 catalytic converters would take a while to warm up if that system wasn't working. I knew 4v cobras had an air feed for the cats but didn't realize until I saw the fuse that it was on GTs too.

Like I said, it was a hasty swap, and a hodgepodge of 96 and 99 parts with a safe tune. I know I would've been sorely tempted to bypass it and call it a day if I had been the one piecing everything together
B0jangles is offline  
post #6 of 6 Old 04-08-2016, 03:50 AM Thread Starter
Registered User
 
B0jangles's Avatar
 
Trader Feedback: (0)
Join Date: Jul 2014
Location: California
Posts: 334
Garage
Quote:
Originally Posted by indy2000 View Post
put a test light to batt pos, and probe both pins.

if there is a short to ground, it will light up

then go find it.
Ha and hope it isn't a wire that's wrapped up in the harness. But I knew something was fishy for a while.

Thanks for the tip, I'll post again when I dig into it. There's something weird in there somewhere
B0jangles is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale Pre-Production 1996 Ford Mustang Cobra waldo Mustangs For Sale/Wanted, 1994-1998 0 01-23-2016 11:13 PM
1996 Mustang Convertible Power Window Drop Issues jammindj1 GT & SOHC 5 01-22-2016 09:11 PM
For Sale FS: 1996 Mustang Cobra wheels 17x8 7k miles rharvey123 Rims Wheels and Tires 1 05-18-2014 09:47 AM
Home Electrical Question Paully's5.0 Lounge 0 12-28-2013 05:36 PM
For Sale For Sale: 1996 Cobra LLX3 computer & PATS equipment Tabres Electronics and Entertainment 3 03-06-2012 03:36 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome