Clicking under hood no start - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 02-21-2016, 03:25 AM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Feb 2016
Posts: 8
Clicking under hood no start

93 5.0 When I turn my key on I hear clicking under the hood it sounds like relay chatter. I re grounded the grounds next to the battery and that made it ok for a few starts. The problem is back no matter how I ground the grounds by the battery I still hear clicking. With the fuel pump relay is in the clicking is real loud and the pump runs continuous. When I unplug I hear clicking from somewhere else but I can't pin point it. As the clicking starts the check engine light flickers.
Dose anyone have a diagram of grounds ?
Has anyone had this problem before ?
What relays are under the hood?
Are there any computers or modules under the hood that could make this noise?
Thanks

Rogie is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-21-2016, 10:28 AM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
key can be in 'run' or 'crank',

what are you talking about?

you need a good wiring diagram, its called an EVTM, or look at the sticky.

so you can test circuits.........

is this a stock ecm, no chip?

try a code reader, and see what happens, but a flickering CEL, is usually an issue with a poor ECM ground, or a 5volt ref short to ground......

you are going to have fun now......


89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #3 of 6 Old 02-21-2016, 02:31 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Feb 2016
Posts: 8
Key in run
What is a 5 volt ref short , stock no chip

Last edited by Rogie; 02-21-2016 at 02:49 PM. Reason: Add answer
Rogie is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 02-21-2016, 02:58 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
comm circuit for all sensors

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
post #5 of 6 Old 02-21-2016, 06:18 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Feb 2016
Posts: 8
Unplugged distributed and some of the noise went away the remaining noise sounds like the injectors pulsing.
Is the computer's only ground on the inner fender next to the battery?
Could not find sticky with wire diagram where is a good source to get a good wire diagram?
Suspect a bad computer but I don't know what pins to check to verify good source power and ground
Car has been sitting before I got it and it is a covertable I think moisture has been in the car since I had to replace all 4 power window motors and both lock solenoids
The dimmer switch is buggy ( possibly corroded ) I wonder if the ignition switch ( if corroded) could cause this flicker?
Can I jump power to the computer to eliminate the chance of the ignition switch causing this problem ?
Rogie is offline  
post #6 of 6 Old 02-21-2016, 06:45 PM
Registered User
 
indy2000's Avatar
 
Trader Feedback: (3)
Join Date: Oct 2001
Location: vancouver
Posts: 21,304
evtm

bbb industries

for diagrams

89 GT gr-40, KB2200(10psi), tweecer R/T,LC-1, 22gal cell, w/tailpipes.
indy2000 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale New H.O. Fibertrends 1994-1998 Cobra R Hood - pickup only krazyrabbit Exterior Parts 4 07-22-2013 07:21 PM
Cervinis 3.5 Cowl hood on 94 Mustang GT JT_93Stang The Body Shop 3 09-03-2012 01:04 PM
Wont stay running and wont start without starter fluid. Fuel Problem? Hunter00GT GT & SOHC 7 03-10-2011 11:26 AM
hood clearance issues strker347 The Body Shop 0 12-07-2010 05:40 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome