Turn signal problems (Moved from 94/95 Tech) - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 12-23-2002, 10:28 AM Thread Starter
Registered User
 
Trader Feedback: (2)
Join Date: Dec 2002
Location: USA
Posts: 210
Exclamation Turn signal problems (Moved from 94/95 Tech)

MY turn signals doesnt work and after a minute the turn signals work again. Sometime the hazzard light does the same thing too, or only one light flashes. Happen sometime when i start the car and hit the turn signal or the hazzard light

All the fuses and the bulbs are ok.
Please help.

philmiup is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 12-23-2002, 11:05 AM
Registered User
 
Don 95Vert's Avatar
 
Trader Feedback: (4)
Join Date: Nov 1999
Location: Delaware, OH
Posts: 3,529
Replace the multifunction switch in the steering column.


95 Lightning - Slow
95 Convertible 357 turbo
10.5/135 @ 3800#
SCT Tuned

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Don 95Vert is offline  
post #3 of 7 Old 12-23-2002, 11:07 AM
 
Trader Feedback: (0)
Join Date: Dec 2002
Posts: 9
Temp fix - when you turn on your turn signal, pull the lever in towards you a tiny bit, should be enough to pic up contacts, but dont pull it far enough for the high beams to turn on.
MehakGT is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 12-23-2002, 11:34 AM Thread Starter
Registered User
 
Trader Feedback: (2)
Join Date: Dec 2002
Location: USA
Posts: 210
Even if the wiper work the swtich can be broken??

Anyway I already replace the multifunction switch in the steering column and the problems still exist.
philmiup is offline  
post #5 of 7 Old 12-23-2002, 12:20 PM
Registered User
 
94CobraPace's Avatar
 
Trader Feedback: (13)
Join Date: Sep 2000
Location: Houston, Texas
Posts: 3,249
Might try and replace the flasher under the dash?? Give it a try, it might be getting hot and stop working, then when it cools it starts working again.
Also check all your lights and make sure they work.

2010 Shelby GT500, Kona Blue W silver stripes.
2007 Shelby GT500, Vista Blue with Tungston gray stripes, 1 of 119, Wifes car...
94 Cobra Pace car Convertible # 591
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2001 Cobra vert # 2001 SOLD
94CobraPace is offline  
post #6 of 7 Old 12-23-2002, 12:52 PM Thread Starter
Registered User
 
Trader Feedback: (2)
Join Date: Dec 2002
Location: USA
Posts: 210
how can the flasher be hot if the car havent been started for couple of hours??

Will try to replace the flasher??

Is there 2 different flasher one for the turn signal and the other for the hazzard??

where are the flasher located in the car??
philmiup is offline  
post #7 of 7 Old 12-23-2002, 02:35 PM
Registered User
 
94SVT's Avatar
 
Trader Feedback: (0)
Join Date: Dec 2001
Location: Scottsdale, Arizona
Posts: 533
Have you checked your blinker fluid lately? might be low...

Seriously, I agree with cobrapace check the flasher relay under he dash. turn on your blinkers (when they are working) and crawl under the dash and listen for it.
94SVT is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wierd Turn signal, High Beam problems Juiced408W General Mustang Tech 6 12-21-2010 03:10 PM
S-Trim Discharge Tube (Moved from 94/95 Tech) bnhokie Superchargers 18 10-16-2002 08:20 AM
Electrical problems (Moved from 94/95 Tech) Black94GTvert Electrical & Wiring 11 10-07-2002 10:15 AM
VORTECH / MSD BTM WIRING (Moved from 94/95 Tech) WWS95GT Electrical & Wiring 2 07-22-2002 04:50 PM
315 and no panard bar (Moved from 94/95 Tech) Insley95 Wheels and Tires 8 07-11-2002 10:54 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome