Low battery light on (Moved from 94/95 Tech) - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 10-14-2002, 01:33 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Dec 2000
Posts: 73
Low battery light on (Moved from 94/95 Tech)

Quick question regarding the dash battery light. On my way to work this morning I glanced down to see my red battery light on & the needle on the gauge between the "N" & "O" on NORMAL. This is the first time the light has ever came on, & the battery is fairly new. Last night got down to about 35 degrees if that may have an impact on anything. I have driven the car about 10 miles since I first noticed this. If it was the alternator, would'nt the car die out quickly? Any suggestions?

JAKESSNAKE is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 10-14-2002, 02:02 PM
 
Trader Feedback: (0)
Join Date: Feb 2002
Posts: 12
first, check to c if ur alt is charging w/volt meter should be around 13-14.5 volts (i think) ne thing lower is not charging. then, check ur wires by the ignition selenoide & alt.

unknown is offline  
post #3 of 7 Old 10-14-2002, 02:03 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Dec 2000
Posts: 73
Maybe a bad voltage regulator? Is that a part of the actual alternator?
JAKESSNAKE is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 10-15-2002, 07:17 AM
 
Trader Feedback: (0)
Join Date: Jul 2000
Posts: 452
Voltage regulator is part of the alternator...

Check to make sure all connections are good and have the alternator tested at your local parts store. You can drive without an alternator until the battery is drained, not usually that long.
brock95gt is offline  
post #5 of 7 Old 10-15-2002, 09:32 AM
Registered User
 
GDAVENPORT's Avatar
 
Trader Feedback: (2)
Join Date: Mar 2000
Location: Houston, TX
Posts: 1,440
this exact thing happened to me last night.

this morning and a new 130 amp alternator (151$ AutoZone) later, and I am back in business.

the Battery light came on (for the first time ever), after driving around and getting voltage spikes upwards of 16-17 volts!!! then, after pulling out of the gas station, nothing but battery voltage.

I have had an alternator go out before (two years ago). I was able to drive the car for 5+ miles before the battery was completely dead (new battery).

Hope this helps.

Guy
_______
95 Red Cobra 357RWHP/386RWTQ TW heads, TwEECer, TFS R, 36 lbers/PRoM 77,70mm TB, 347, Al flywhl, 1 3/4 LTs, Dr. Gas X, 3" out the back phb/ta, griggs C/O MM C.C plates
GDAVENPORT is offline  
post #6 of 7 Old 10-15-2002, 09:56 AM
Registered User
 
rel3rd's Avatar
 
Trader Feedback: (34)
Join Date: Mar 2000
Location: Baltimore, Maryland
Posts: 4,265
That's almost funny Guy...The same exact thing happened to me a week and a half ago. Driving home from work, all was well. I stopped at the gas station, all was still well. I started the car and as I pulled out of the place, I see my battery light come on....Went home (I was about 3-4 miles away), and checked the charging system with a voltage meter....11 volts

$150 later, all is well....

2 Mustangs and a LOUDASS Harley
rel3rd is offline  
post #7 of 7 Old 10-15-2002, 10:15 AM
Registered User
 
GDAVENPORT's Avatar
 
Trader Feedback: (2)
Join Date: Mar 2000
Location: Houston, TX
Posts: 1,440


Yeah, thats not cool... mine was under warranty, in another state, and I cannot find out which store it was purchased from

Optima Alternator 130 amps?... any one?

The good news is that I am soo good at taking it off, its not funny... it only took me 10 minutes last night.....
GDAVENPORT is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Light Nightmare Wreckless Hype Electrical & Wiring 3 11-18-2011 11:00 PM
true you can run procharger w/o any other fuel mods? (Moved from 94/95 Tech) FastGT94 Superchargers 1 10-02-2002 04:35 PM
Question about fan (Moved from 94/95 Tech) HPLouis Electrical & Wiring 2 07-04-2002 10:48 AM
Fan won't shut off (thread moved from 94/95 Tech) 95CobraofDeath Electrical & Wiring 2 06-25-2002 02:06 PM
Electric fan stopped working (moved from 94/95 Tech) johnperdeye Electrical & Wiring 3 06-25-2002 01:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome