fan not working - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-12-2002, 12:21 PM Thread Starter
 
Trader Feedback: (0)
Join Date: Nov 1999
Posts: 142
fan not working

The topic says it. I hotwire the fan to the battery, and it spun like a champ. At that point I cleaned the connector on it, still nothing. So I then thought it must be the relay, replaced it and still nothing.

Please help I have no idea wtf is going on and its REALLY pissing me off.

Thanks in advance.

Jon 94GT is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-12-2002, 12:28 PM
Registered User
 
erik_94COBRA's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2000
Location: Brazoria, TX (houston area)
Posts: 591
ECT sensor?


Erik
'94 Cobra #2182
erik_94COBRA is offline  
post #3 of 3 Old 10-12-2002, 12:55 PM
 
Trader Feedback: (0)
Join Date: Oct 2001
Posts: 399
Run the KOEO test. It turns the fan on low and then High speed at the beginning of the test. If it turns on during the test, you'll know that the relays and EEC outputs are OK. Then look at your ECT sensor.
Brian94Cobra is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting without tune or calibrated maf. 89blkmustang Turbochargers 21 07-04-2018 07:47 AM
Dual contour fans ? sleeping stallion General Mustang Tech 14 07-10-2013 02:10 PM
Fan not working correctly BIGDATOWN 94/95 Tech 3 08-26-2011 08:52 AM
Electric fan swap screws with my wideband boosted302sleeper Electrical & Wiring 2 07-30-2011 12:38 AM
overheating cause fan is not working 95DropTop 94/95 Tech 4 07-25-2002 10:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome