Fuel pump wont prime... - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-17-2012, 02:56 AM Thread Starter
Registered User
 
91vertgt's Avatar
 
Trader Feedback: (6)
Join Date: Jun 2010
Location: ephrata pa
Posts: 287
Fuel pump wont prime...

I just installed a BBK 255 in my car it was new out of the packaging and when i turn the key on it wont prime the pump. I dropped the tank again and checked all the connections it looks good. It had a 190 in it so i didnt have to change the wire plug that came with the pump. The relay is new and i can hear it click when i turn the key on. Is there another fuse i should check? Or anything i can check. If anyone has a pic of the wire connector that is at the back of the tank that goes to the pump and knows what pins are witch so i can put power and ground to them and make sure the pump works that would be great.

91vertgt is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-17-2012, 10:44 AM
Registered User
 
Trader Feedback: (9)
Join Date: May 2002
Location: New Braunfels TX
Posts: 4,477
Check your inertia switch.


'94 GT, White, Cobra hood & bumper cover, '95R wheels
393w, Vic Jr 60cc, XE282HR, Victor 5.8 EFI, 80# injectors, Hooker LT 1 3/4 to 3", Borla proXS
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

T56 w/ AJE xmember, McLeod street twin, MM/Bilstein '03 IRS, JRi Agent47 SLA
Megasquirt
seijirou is offline  
post #3 of 5 Old 06-17-2012, 02:06 PM Thread Starter
Registered User
 
91vertgt's Avatar
 
Trader Feedback: (6)
Join Date: Jun 2010
Location: ephrata pa
Posts: 287
I did its fine
91vertgt is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 06-17-2012, 02:16 PM
Registered User
 
Trader Feedback: (9)
Join Date: May 2002
Location: New Braunfels TX
Posts: 4,477
Have you checked for power at the fuel pump relay?

The red wire should have 12 volts when the key is on.
The computer provides ground for the relay on the Tan/light green wire. If you hear the relay clicking I assume both of these are good.

The black/orange wire has battery power, and it should always read + volts. Even if the relay works, no juice in means no juice out.

Finally the Pink/black wire is what sends power to the fuel pump. If everything above checks out and the relay is good, you should have power on the pink/black wire briefly after turning the key on.

That power passes through the inertia switch then to the fuel pump. The fuel pump is just 2 wires, power and ground.

'94 GT, White, Cobra hood & bumper cover, '95R wheels
393w, Vic Jr 60cc, XE282HR, Victor 5.8 EFI, 80# injectors, Hooker LT 1 3/4 to 3", Borla proXS
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

T56 w/ AJE xmember, McLeod street twin, MM/Bilstein '03 IRS, JRi Agent47 SLA
Megasquirt
seijirou is offline  
post #5 of 5 Old 06-18-2012, 12:59 AM Thread Starter
Registered User
 
91vertgt's Avatar
 
Trader Feedback: (6)
Join Date: Jun 2010
Location: ephrata pa
Posts: 287
Yes it all has power and i unplugged the wires at the back of the tank and put power and ground to it and the pump just makes a click sound and does not run. When i put the 190lph pump back in it all works fine so i am ordering a new 340lph pump tomorrow if bbk does not warranty this pump for me
91vertgt is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Question about The Fuel Pump Driver Module (FPDM) G-Pete Superchargers 6 07-19-2011 09:45 PM
Battery strong enough to crank engine, not strong enough to prime fuel pump? 83GT5.0 Engine Management Systems 4 03-04-2011 09:14 AM
Walbro GSS340 Fuel Pump Install a50sn95 General Mustang Tech 0 12-14-2001 09:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome