Right marker light not working on my 04 GT... - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-02-2012, 02:49 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Aug 2009
Location: Westchester
Posts: 9
Right marker light not working on my 04 GT...

Hey all, just purchased a 2004 GT with 75k (finally). I absolutely love it, it's a blast to drive.

Anyway, the passenger marker light isn't working - I replaced the bulb thinking it would solve the issue, it didn't. The turn signal works absolutely fine, it's when the headlights are on - the amber light that is supposed to constantly be on, isn't. What a weird thing.


Any help is greatly appreciated and thank you in advance. It's great to finally be a part of the Mustang club!

5.0-Thrill is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-03-2012, 03:04 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Aug 2009
Location: Westchester
Posts: 9
Bump. Just drove it down to Yonkers to see some family. Love it, just wish I could figure this stupid light out.

5.0-Thrill is offline  
post #3 of 5 Old 06-04-2012, 07:40 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Aug 2009
Location: Westchester
Posts: 9
Bump. The wires look ok. I'm beyond stumped.
5.0-Thrill is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 06-04-2012, 10:23 PM
Registered User
 
wmburns's Avatar
 
Trader Feedback: (0)
Join Date: Apr 2012
Location: Houston
Posts: 272
Did you test for +12 to the socket with the lights on?
wmburns is offline  
post #5 of 5 Old 06-27-2012, 04:06 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Aug 2009
Location: Westchester
Posts: 9
Figured it out!


It turns out that one of the three connector prongs that connect to the socket wasn't reaching the prongs on the bulb socket. The previous owner probably tried to pull the bulb harness out by the wires and just pulled one of them out. So I pushed the wire in, held it in place, plugged the bulb socket back in and it worked! All lights work like a charm.
5.0-Thrill is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 Gt Convertible (CDC Light bar poll) RoysGray88 GT & SOHC 15 04-21-2012 04:09 PM
LED LIGHT BULBS FOR 1988 MUSTANG GT Mercedez L. General Mustang Tech 2 04-06-2012 11:26 AM
For Sale GT tail light buckets greenhornet923 Exterior Parts 3 05-18-2011 06:04 PM
Both headlamps stopped working on 03 GT MustangLife GT & SOHC 5 02-08-2011 06:46 AM
1989 GT power brakes stopped working Jess1313 General Mustang Tech 5 12-03-2010 10:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome