These dam* turn signals!!! - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 02-14-2012, 01:44 PM Thread Starter
Registered User
 
SouthernStang's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2012
Location: Alabama
Posts: 17
These dam* turn signals!!!

So i just recently purchased an 88 lx with a 5.0 etc etc. The turn signals do not work BUT the hazards do..i have researched for days and found alot of people had this problem and it turned out to be the turn signal flasher..na-ah , not here..so after downloading a couple wiring diagrams and wearing out my test light i have come to this..i have NO POWER going to the turn signal flasher plug..It has 2 purple wires with orange stripes coming out of one side and a blue wire out of the other..I figure the ppl/org wires run into the back of the fuse panel at fuse #5 (which of course i could not get a power reading for)Hell if i know where the blue one goes..I understand that there is a grey wire with yellow stripe from the ignition switch connector that supposedly powers fuse #5 and #8..i stick a test light to it with key off key on key backwards and no power but the yellow wires do have power...so it couldnt be the that ign. switch connector right? wtf is going on here? lol i know my problem is obviously no power to the turn signal flasher but im kinda stumped on where it may be losing power at..any help would be TREMENDOUSLY appreciated..thanks


'88 LX Mustang.H/C/I , geared
'87 LX Mustang.H/C/I , Supercharged , geared.
SouthernStang is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 02-15-2012, 02:57 AM
Registered User
 
Trader Feedback: (2)
Join Date: May 2005
Location: Yakima, WA
Posts: 1,087
The two yellow wires come from the battery so they should have power. The G/Y wires should have power with the ignition switch in the 'Run' position.

Saleen0679 is offline  
post #3 of 5 Old 02-15-2012, 07:07 PM Thread Starter
Registered User
 
SouthernStang's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2012
Location: Alabama
Posts: 17
yes i was messing around and figured that no brainer out yesterday lol..started the car to let it run (been rlly cold lately) and hit the wires with light and they have power to them..same with turn signal flasher..it has power when running but still no turn signals.has got to be the turn signal (multi-function) switch..thanks for the info.

'88 LX Mustang.H/C/I , geared
'87 LX Mustang.H/C/I , Supercharged , geared.
SouthernStang is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 03-01-2012, 12:26 AM
Registered User
 
Trader Feedback: (38)
Join Date: Apr 2006
Location: allentown, PA
Posts: 564
check the harness that goes into the 4 way flasher switch... the pins get burnt and pull out ive fixed quite a few of these.... i might have a pig tail if you want with a good plug.... if i have it ill send it for free!

1988 notch
erich306 is offline  
post #5 of 5 Old 03-01-2012, 08:08 PM Thread Starter
Registered User
 
SouthernStang's Avatar
 
Trader Feedback: (0)
Join Date: Feb 2012
Location: Alabama
Posts: 17
well fellas i put another turn signal switch in but my problem was the hazard light switch...oddly enough i could squeeze it together after i took it out of the dash and the turn signals would start working..the clips that hold it together where broken.Initially i thought maybe it coulda been the orange wire with yellow stripe running in the back of the hazard switch but turns out it was just a bad hazard switch..i ran a zip tie around it and tightened it up so itd pull it together...the wires were not getting good connection i guess..strange lol

erich it seems like all my plugs are like that..lol

'88 LX Mustang.H/C/I , geared
'87 LX Mustang.H/C/I , Supercharged , geared.
SouthernStang is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signals not working.. Now fixed but have questions.. sscherin Electrical & Wiring 1 11-28-2011 05:24 PM
Hopefully the rain stops at Dover,,any other Nascar fans??? NJ5pnt0 Lounge 33 05-18-2011 09:57 PM
Turn signals quit working? DeMartino17 General Mustang Tech 6 05-10-2011 10:39 PM
Turn signals come on but do not flash gtcobra302 General Mustang Tech 8 01-15-2011 01:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome