Charging problem - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-14-2012, 10:37 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Jan 2009
Location: Anaheim, CA
Posts: 56
Charging problem

Hey guys, so I recently had my head gaskets changed and about 3 weeks later I started having charging issues. Today I replaced the alternator and battery and I only made it through a 30 mon drive until my car died. Other than ground wiring can this be an issue with me ecu harness if it has gotten torn at all or should my alternator work fine as long as its ground and power cable are connected? And should I check any fuses? Please help.


Sent from my Autoguide iPhone app

sean 98 gt is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
90' Charging Problem Leeiswho2b Electrical & Wiring 1 01-16-2012 10:46 AM
Charging problem silver408coupe General Mustang Tech 2 04-16-2011 07:08 AM
1991 charging problem mattstang'91 General Mustang Tech 2 03-02-2011 08:50 PM
Not your typical charging problem... J's 89 5.0/5.8 Engine Tech 5 01-30-2003 03:30 PM
charging system and wiring experts help me diagnose this problem demon357 General Mustang Tech 1 01-08-2002 09:09 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome