Electrical problem help - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-07-2012, 01:35 PM Thread Starter
Registered User
 
ChromeCobra's Avatar
 
Trader Feedback: (3)
Join Date: Jan 2006
Location: South Elgin
Posts: 92
Electrical problem help

I'm am having a problem with my '98 Cobra that I just cannot figure out. I searched threads and found that people have had the same problem but I couldn't find a solution to it.

Gauge cluster, HVAC control, license plate, and parking/running lights do not illuminate. The headlights, foglamps, turnsignals, and brake lights do still work perfectly though.

The #13 fuse was blown, I replaced it and they still don't work. I also replaced the headlight switch and that also didn't fix anything. I checked all obvious wires and grounds and everything looks good.

Does anyone have any ideas?

ChromeCobra is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-07-2012, 09:03 PM
Registered User
 
Trader Feedback: (2)
Join Date: May 2005
Location: Yakima, WA
Posts: 1,087
Is fuse #5 good?

Saleen0679 is offline  
post #3 of 4 Old 01-07-2012, 11:05 PM Thread Starter
Registered User
 
ChromeCobra's Avatar
 
Trader Feedback: (3)
Join Date: Jan 2006
Location: South Elgin
Posts: 92
Every fuse is good, thanks though.
ChromeCobra is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 01-08-2012, 08:16 PM
Registered User
 
Trader Feedback: (0)
Join Date: Jan 2006
Location: West Virginia
Posts: 29
What about connection behind the fuse box? I had a wire burn in half one time and cause similiar problems. Especially considering the blown fuse. Take a DMM or test light over the fuse with power on to make sure there is power on the fuse.
Leeiswho2b is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
89 lx electrical problem??? chris306 General Mustang Tech 4 08-25-2011 10:14 AM
89 electrical problem HELP chris306 Electrical & Wiring 1 08-24-2011 11:02 PM
is it my transmission? or is it an electrical problem? notchahead93 General Mustang Tech 1 11-23-2010 06:47 PM
What's up with the rough idle? Maybe electrical problem? progresr GT & SOHC 10 07-03-2003 08:58 AM
Electrical problem: instrument panel lights won't turn on ASpaceman General Mustang Tech 15 02-11-2002 11:15 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome