AC Relay question..pls help..its hot here in FL still - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-23-2011, 10:16 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Sep 2011
Location: Orlando, FL
Posts: 1
AC Relay question..pls help..its hot here in FL still

Hello all...new to the boards and have already learned a ton! Hoping someone can help me out. I just bought a 93 Mustang LX Coupe that the previous owner installed a crate motor 306 in. Before doing so, he took everything out of the engine compartment, sand blasted it...etc...the right way. All AC was said to be working at the time everything was pulled. When I turn on the air, the blower motor comes on, but the AC clutch does not engage. I replaced the clutch cycling switch and toped off the R134 so the pressure is good (around 55 at 90 degrees) . I can get the ac to run cold when I jumper wire the positive side of the compressor. I then figured it was the AC relay. I purchased on from Pepboys...but cannot locate the relay ANYWHERE. There are no wires in the passenger fender anywhere (I even pulled the fender well back. I cant find it on the drivers side, or under the dash or behind the kick pannels anywhere. I did notice that there are 3 unconnected/unused connectors coming off the harness by the condensor. Could it be that there is a missing harness that plugs into one or all of these? ANY help at all...including PHOTOS would be greatly appreciated!!! Thanks again to all for the warm welcome to the boards. Ron


PS...even just a photo of the relay and what the wires look like and where the lead to would really help....

CoupeRon is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1986 GT Fuel pump not priming 86bigred General Mustang Tech 7 11-03-2011 06:50 AM
Fox a/c question, what is the hot wire? mustangsrule General Mustang Tech 5 08-03-2011 12:33 PM
Fox a/c question, what is the hot wire? mustangsrule Electrical & Wiring 0 08-03-2011 07:16 AM
relay wiring question w/pic. steel1 General Mustang Tech 3 01-23-2011 01:41 PM
New Starter & Relay.. Still not hot start??? 5.0Trunk 5.0/5.8 Engine Tech 5 01-13-2002 02:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome