turn signals not working - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-18-2011, 10:06 AM Thread Starter
Registered User
 
Trader Feedback: (11)
Join Date: Nov 2005
Location: plainfield in
Posts: 419
turn signals not working

My turn signals seem to stop working and so did the wipers. I know the signals work because the hazards work. Im thinking maybe something happened to the signal lever since the wipers arnt working either. Is there wiring or a connector to check on it?

davidz is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-18-2011, 12:13 PM
Registered User
 
swetrid's Avatar
 
Trader Feedback: (16)
Join Date: Jul 2011
Location: Reading Pa
Posts: 789
Too help better, what year are you working on? If it is fox body there is a separate flasher for turn signals behind glove box area. Hazard flasher is in fuse box on driver side.


Ex Ford tech for last 17 years! 2016 Triple Yellow California Special
swetrid is offline  
post #3 of 4 Old 09-18-2011, 01:01 PM Thread Starter
Registered User
 
Trader Feedback: (11)
Join Date: Nov 2005
Location: plainfield in
Posts: 419
its on an 89. so are you saying there is a fuse or something behind the glove box for the turn signals? I was thinking it might have somthing to do with the wireing to the lever on the steering colum because I took the plastic pieces off the colum to paint them and maybe I disconnected something?
davidz is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 09-18-2011, 04:05 PM
Registered User
 
swetrid's Avatar
 
Trader Feedback: (16)
Join Date: Jul 2011
Location: Reading Pa
Posts: 789
Open glove box and the flasher is at the top on the left side. It should be round and silver in color to help you.

Ex Ford tech for last 17 years! 2016 Triple Yellow California Special
swetrid is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hopefully the rain stops at Dover,,any other Nascar fans??? NJ5pnt0 Lounge 33 05-18-2011 09:57 PM
Turn signals quit working? DeMartino17 General Mustang Tech 6 05-10-2011 10:39 PM
Turn signals come on but do not flash gtcobra302 General Mustang Tech 8 01-15-2011 01:42 PM
Turn Signals not working fastfed General Mustang Tech 8 05-11-2005 10:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome