power window electrical problems - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 02-18-2011, 09:08 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: Feb 2011
Location: easley sc
Posts: 17
power window electrical problems

hi guys ive got a problem with my passenger side power window that is cureently not working.i have 12 volts dc on the pink wire at the switch.when i unhook the motor and put my meter leads on the tab inside the quick connect for the motor i have 12 volts to ground when the switch is in the down position on the red wire and 12 volts to ground when the switch is in the up position on the yellow wire.i took the switch out of the circuit and checked continuity and all is ok with the switch.the problem comes when i plug the motor up.with the motor plugged up i have 12 volts on both the red and yellow wires whether the switch is in the up or down position.my first thought was a faulty motor so i removed the motor from the drivers side and plugged it in and got the same result........any ideas????

skeezer is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-21-2011, 03:09 PM
Registered User
 
Trader Feedback: (2)
Join Date: Nov 2010
Location: Orlando FL
Posts: 149
Quote:
Originally Posted by skeezer View Post
hi guys ive got a problem with my passenger side power window that is cureently not working.i have 12 volts dc on the pink wire at the switch.when i unhook the motor and put my meter leads on the tab inside the quick connect for the motor i have 12 volts to ground when the switch is in the down position on the red wire and 12 volts to ground when the switch is in the up position on the yellow wire.i took the switch out of the circuit and checked continuity and all is ok with the switch.the problem comes when i plug the motor up.with the motor plugged up i have 12 volts on both the red and yellow wires whether the switch is in the up or down position.my first thought was a faulty motor so i removed the motor from the drivers side and plugged it in and got the same result........any ideas????
i think i'm having the exact same problem with my drivers side window did you find a fix?

inca1982 is offline  
post #3 of 3 Old 04-01-2011, 06:28 PM
Registered User
 
Trader Feedback: (0)
Join Date: Feb 2009
Location: Indianapolis
Posts: 51
Garage
Have you tried a set of jumper wires from your battery to the motor to see if it is working right? If you have voltage when you push the switch and thats working right I would say replace the motor. Is your other window working ok?
gt92mustang is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
FR500TT Big Bore Boss-Stroked and Boosted w/Ethanol! Turbo98 SVT & DOHC 359 12-10-2012 09:05 PM
Power Window support is trashed - what to do? Jeff Dude GT & SOHC 5 02-18-2011 07:50 AM
power window problems...87 coupe bottlefedgt General Mustang Tech 5 11-17-2010 08:01 PM
Power window problems Saleen308 General Mustang Tech 1 12-22-2001 11:09 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome