mustang problems - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-21-2002, 05:51 AM Thread Starter
 
Trader Feedback: (0)
Join Date: Nov 2001
Posts: 71
mustang problems

After getting my stang out of the body shop I noticed that occasionally my instrument cluster lights and shifter lights would not come on. I just messed with the fuse under the hood and then they worked. I thought that the fuse was just bad. I checked the fuse under the steering wheel and it was good. I checked the fuse under the hood and it was good. The fuse that goes to the instrument cluster also goest to the parking lights, which also aren't working. It also goes to the hood and trunk lights which are working. I have no clue as to what could be wrong. I just know that I can't be driving at night until I get this fixed. I didn't have this problem before I took my stang in to the body shop. Is it possible that when they were working on the fenders that they could have messed something else up? Any suggestions as to what could cause this. Oh, I almost forgot, the Airbag light is now flashing and staying on, it is also connected to the same fuse.

Haldanite is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-21-2002, 01:22 PM
 
Trader Feedback: (0)
Join Date: Dec 2000
Posts: 167
electrical are the worst to try and diagnose on a forum...too many variables. here is my guess..

sometimes the flashing airbag light is giving a trouble code. you should scan codes or watch the light and see if it is counting something out...

As for the lights....maybe the shop forgot to connect a ground wire somewhere...

maybe the lights and the airbag use the same ground that is not connected.

good luck.

slo95 is offline  
post #3 of 4 Old 06-21-2002, 01:44 PM
Registered User
 
scoupe89's Avatar
 
Trader Feedback: (2)
Join Date: Feb 2001
Location: Phoenix, AZ
Posts: 1,790
Could be coincidence or poor workmanship from the body shop. Call them and see what they say. Seen stranger stuff happen.



Could be a dirty dimmer/headlight switch. Try some electrical cleaner sprayed into the staft seal. You should at least see a flicker.

I have lost the cluster lights and have a short somewhere as the fuse under the hood is good, but every time I replace the under dash, it pops. Let me know what you find.

2013 Ford Explorer XLT
2007 Ford F-150 XLT 5.4 Supercab 4x4
Supercharged 1994 GT 5.0 vert - sold
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by scoupe89; 06-21-2002 at 01:49 PM.
scoupe89 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 06-22-2002, 12:00 AM Thread Starter
 
Trader Feedback: (0)
Join Date: Nov 2001
Posts: 71
Thanks for the help everyone. I decided to check every fuse that I could find with no luck. I even replaced the good fuse under the hood with no luck. I also disconnected the battery for several hours to reset the computer with no luck.

Quote:
watch the light and see if it is counting something out...
How would I know if it was counting something out? It does flash several times in what seems to be an orderly function before it just goes on for good.

I'm going to call the body shop in the morning and see if they will fix it. They are good people, so I bet that if they could have messed it up, they will look into it.
Haldanite is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2015 Ford Mustang EcoBoost vs Subaru WRX AG Jeff News 0 11-03-2015 02:51 PM
4.6 DOHC question. Rfreeman37 SVT & DOHC 313 01-07-2014 10:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome