Voltage Drop - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-24-2002, 11:38 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2000
Location: Columbus, Ohio USA
Posts: 203
Voltage Drop

I have been experiencing voltage drop for about 3 months. I have checked grounds, my negative battery cable connects to the engine near the oil pressure sending unit, and I have another ground strap from the block to the front subframe near the swaybar connection. Am I missing a ground somewhere? It does it a little with the head lights on (my temp and oil pressure jump maybe a letter), but when the fan kicks on, it's more like a 2-3 letter jump, headlights or no headlights. It's not my fan groundwire that I can tell, it's resistance between the connector and the negative battery terminal is .02 ohms. Any harm in trying to ground the fan directly to the battery terminal? Any ideas?


'95 GT
-DSS low comp. 306/GT-40Y/Cobra U/L
-DIY Single Turbo - Holset WH1E @ 7psi intercooled
Powershift95GT is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-25-2002, 09:11 AM
 
Trader Feedback: (0)
Join Date: Dec 2001
Posts: 232
I don't want to be "Captain Obvious" here, as you probably have already thought of it, but when did you install your under drive pulleys? Since mine have been on, I constantly check the voltage while idling, and rev occasionally to keep the battery charged. Good luck. Just a shot in the dark...

Matt

whitesn95gt is offline  
post #3 of 3 Old 05-25-2002, 09:16 AM
 
Trader Feedback: (0)
Join Date: Jul 2000
Posts: 452
Check your alternator and its connections, you do not use the battery to power your accessories while the engine is running you use the alterntor.
brock95gt is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Drop Some Knowledge On Me...fuel pump, injector, boost-a-pump calcs KennethRisher General Mustang Tech 27 09-03-2014 08:43 AM
02 sensors low voltage on open loop 94_cobRa 5.0/5.8 Engine Tech 2 11-19-2011 08:58 PM
On3 has done it again...... 2Guard Turbochargers 179 08-13-2011 03:29 AM
Can I Israeli carry my GLOCK 19 while shooting a parking lot thief in NO? Daywalker Lounge 61 03-28-2011 12:15 PM
tps voltage question 86style 5.0/5.8 Engine Tech 8 12-28-2001 08:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome