Launching in 2nd??? - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-06-2008, 05:54 PM Thread Starter
Registered User
 
Trader Feedback: (6)
Join Date: Dec 2007
Location: WI
Posts: 460
Launching in 2nd???

This is probably the dumbest thing I have posted in this board. Has anyone done this with a 5 speed.

If you have read any of my posts I have had the worst time launching my car. Is a turbo and I have noticed that my best runs have been when the car has boged off the line. If it doesn't bog and I leave at 1500-1700rpm and floor it and boost comes in I pretty much blast the tires away. My best 60 foot times are nothing lower than a 2.1.

Is it even possible?

forbanger is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-06-2008, 06:20 PM
Registered User
 
KEVIN$'s Avatar
 
Trader Feedback: (8)
Join Date: Nov 2001
Location: Lincoln NE
Posts: 3,894
I tried it a looong time ago and smoked the clutch. Technically I didn't smoke it b/c it was a full bronze puck clutch but it didn't hold at all. There just wasn't enough holding power for 2nd gear launches.

ks



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Kevin Slaby
2002 GT 2V 902hp/820tq through the muffs.
http://baselinesuspensions.com/Projects/balrog.htm
KEVIN$ is online now  
post #3 of 4 Old 10-06-2008, 06:22 PM
Registered User
 
Trader Feedback: (2)
Join Date: Oct 2007
Location: st catharines
Posts: 135
try a better tire and better suspension. i had a fwd turbo car that made good numbers and i had to learn about throttle control. i got it down to a science where i was pumping rwd cars out of the hole, vettes, stangs, f bodies. if i didnt pump them id hang them from a dig and thats all on a steet tire. so practice thottle control. or get a boost controller, launch the car on a low boost setting, hit second gear and switch over to a higher setting.
uchi is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 10-06-2008, 09:25 PM Thread Starter
Registered User
 
Trader Feedback: (6)
Join Date: Dec 2007
Location: WI
Posts: 460
I know I still have to tinker with my suspension. It is still new to me since it is full coil overs. I think the front of the car is tilted too much down.

Another thing is when the boost comes on in first gear is when I waste a lot of time. It literally seems like I sit there for a second until I shift to second.

Tire wise I switched from Nittos to Mickeys. Didn't do a whole lot. I even played with the tire pres a whole lot. I noticed a big difference when I have 21psi on the right and 18psi on the left.

I think it is just me. I can't stop my foot from slamming the gas on the launch...
forbanger is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome