Manual/Reverse valve body C-4 question - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 06-29-2008, 09:17 PM Thread Starter
Registered User
 
jfrenum's Avatar
 
Trader Feedback: (7)
Join Date: Jul 2006
Location: Saratoga Springs, NY
Posts: 195
Manual/Reverse valve body C-4 question

I have a C-4 in my car with reverse pattern, full manual valve body and a transbrake. Around a 2800 stall converter. My question is that when i am in 2nd gear, and let off the gas, it doesn't instantly decelerate (engine brake). It feels good when i am on the gas and doesn't seem to slip or anything like that at any other time.
First, is this normal? I had a C-4 in an old bronco i had, and it wasn't a comp tranny, but it definitely didn't feel like this on a decel.
Also, if it isn't normal, what should i check.


88 Coupe black/black, carb'd 393w, C4, NOS, 5lug/4whl discs, 6pt cage, 3" dumped flowmasters.

88 Escort-daily driver, 50K miles and NEW Camo paint - pics to follow....
jfrenum is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 06-30-2008, 08:02 PM Thread Starter
Registered User
 
jfrenum's Avatar
 
Trader Feedback: (7)
Join Date: Jul 2006
Location: Saratoga Springs, NY
Posts: 195
I guess i should have also said, the main reason i wondered this also, is that when was really getting on the throttle, it puked some tranny fluid out. I checked the level and was a little over full. Would being over full cause either or both of these things to happen?


88 Coupe black/black, carb'd 393w, C4, NOS, 5lug/4whl discs, 6pt cage, 3" dumped flowmasters.

88 Escort-daily driver, 50K miles and NEW Camo paint - pics to follow....
jfrenum is offline  
post #3 of 7 Old 07-01-2008, 08:25 AM
Registered User
 
Trader Feedback: (4)
Join Date: Jun 2000
Location: Baytown, TX USA
Posts: 3,979
Garage
Are you sure it is when you are in 2nd gear and not when you are in first?
My old PA C4 and my current trans king C4 did/do it when I am in 1st gear. Basically you can romp it through the gears, then bump back to 1st quickly and it acts like neutral until it is down to where the speed matches the RPM of the motor. Not in 2nd gear though, 2nd gear decelerates normally.

Carl S.: 417", Yates C3s, Edelbrock 2828, Dominator, Powerglide, 4.10s, 3100 lbs raceweight. 1.27 60' [email protected] nitrous on 275/60 Mickeys in Ultra trim
2014 Ruby Red GT Auto, bone stock for now
http://i269.photobucket.com/albums/jj77/carlrenee1/sigpic1-1.jpg
White90GT is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 07-01-2008, 11:04 AM
Moderator
 
Trader Feedback: (2)
Join Date: Dec 1999
Location: PARTS UNKNOWN
Posts: 370
guy c4's puke easy if over filled where the vent is placed.....
wesb is offline  
post #5 of 7 Old 07-01-2008, 12:15 PM
Registered User
 
nos8ed's Avatar
 
Trader Feedback: (1)
Join Date: Nov 2007
Location: Mustang, OK
Posts: 2,097
Quote:
Originally Posted by White90GT View Post
Are you sure it is when you are in 2nd gear and not when you are in first?
My old PA C4 and my current trans king C4 did/do it when I am in 1st gear. Basically you can romp it through the gears, then bump back to 1st quickly and it acts like neutral until it is down to where the speed matches the RPM of the motor. Not in 2nd gear though, 2nd gear decelerates normally.
X2
Mine is exactly the same way.

90 GT 331 C4 [email protected]
1993 Cobra Black
nos8ed is offline  
post #6 of 7 Old 07-02-2008, 06:09 AM
Registered User
 
cesna150's Avatar
 
Trader Feedback: (29)
Join Date: Apr 2006
Location: jackson mi
Posts: 1,192
same here. no worries.

1993 notch 302 and c4
quicktime turbo system
9.986 @ 136.84
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

"393 stroker and pt88 inthe works"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cesna150 is offline  
post #7 of 7 Old 07-06-2008, 05:35 PM Thread Starter
Registered User
 
jfrenum's Avatar
 
Trader Feedback: (7)
Join Date: Jul 2006
Location: Saratoga Springs, NY
Posts: 195
I know it isn't supposed to decel in first, its fine in that aspect. I am pretty sure i got it figured out.
I think when the fluid would foam up from being over full, it would puke and also cause the decel problem in 2nd. Once i ran it hard for a while and puked most of the extra fluid out, it works fine now.
thanks for the inputs.

88 Coupe black/black, carb'd 393w, C4, NOS, 5lug/4whl discs, 6pt cage, 3" dumped flowmasters.

88 Escort-daily driver, 50K miles and NEW Camo paint - pics to follow....
jfrenum is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome