Looking for rear end for 1967 - Ford Mustang Forums : Corral.net Mustang Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 05-07-2019, 06:49 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2019
Posts: 6
Looking for rear end for 1967

I put a 351 with a FMX transmission in a 67 mustang. It had the wrong rear end. Its too wide for the car. I have new springs and need a rear diff. Where would I look? This is not a race car, just a good looking driver. I restored it from junk. Its at the body shop now. When it comes back, I need to do the interior and rear diff. Engine is done, except the headers. Having a hard time finding ones that fit the rack and pinion connversion. It now has power front disc brakes and AC. Digital dash.

Me and my son did from ground up.

Its a customer car.
David

David_Root is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-07-2019, 06:56 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2019
Posts: 6
I found this when I split the motor and transmission. I had the transmission rebuilt and bought a rebuilt 351W.


Yes, It got a new flex plate and set of proper bolts.



Before


On its first trip to the body shop to have the engine bay painted.


This is the rear end in it now, I can see where the shock mounts and coil spring seats were torched off.



David_Root is offline  
post #3 of 6 Old 05-07-2019, 06:57 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2019
Posts: 6
Complete rewire.

IMG_1068.jpg
David_Root is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 05-07-2019, 07:04 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2019
Posts: 6
I have a vidieo of the engine running and doing a burnout. Don't know how to upload a vidieo.

Thanks for the help.

The fastback was cut off another car and welded on this one. I had nothing to do with that. Floor pans had been replaced . They were glued in, but not welded to the subframe. Car was a total mess.
David

Sent from my SM-T900 using Tapatalk
David_Root is offline  
post #5 of 6 Old 05-07-2019, 07:08 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2019
Posts: 6
David_Root is offline  
post #6 of 6 Old 05-13-2019, 03:11 PM Thread Starter
Registered User
 
Trader Feedback: (0)
Join Date: May 2019
Posts: 6
Bought a new housing using the old gearbox.

David
David_Root is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
TFS Top end kit on stock bottom end? IJUST8UR8 5.0/5.8 Engine Tech 9 04-12-2009 12:53 PM
Let's talk end links... Hawaii_5.0 Road Racing/Auto X 3 10-16-2008 08:27 AM
Ford 8.8 inch rear end carrier - rebuildable? onthesnap General Mustang Tech 10 07-28-2003 07:39 PM
Need Bottom End Torque! Cobra Intake? 88TBirdSport 5.0/5.8 Engine Tech 2 07-07-2002 07:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome