1993 cobra horn, radio, and turn signal not working - Ford Mustang Forums : Corral.net Mustang Forum
Go Back   Ford Mustang Forums : Corral.net Mustang Forum > General Tech Forums > General Mustang Tech

Corral.net is the premier Ford Mustang Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-11-2012, 05:41 PM   #1
Registered User

Trader Feedback: (2)
 
Join Date: May 2001
Location: Apple Valley,MN,U.S.
Posts: 112

1993 cobra horn, radio, and turn signal not working

Drove my car this morning and got to my first turn, turned my blinker on and it didn't work. Turned around and got home and found out my radio and horn didn't work either. The hazards work just no blinkers. Anybody have any trouble shooting I can go through to figure out what it could be?
Thanks Neil.
__________________
1993 teal cobra
331 dart, m2 ported heads, turbo setup.
Neil J is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-11-2012, 06:31 PM   #2
Registered User

Trader Feedback: (2)
 
Join Date: May 2001
Location: Apple Valley,MN,U.S.
Posts: 112

Forgot to mention I did check all the fuses and they were all good.
__________________
1993 teal cobra
331 dart, m2 ported heads, turbo setup.
Neil J is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 09-11-2012, 07:27 PM   #3
Registered User

Trader Feedback: (2)
 
Join Date: May 2005
Location: Yakima, WA
Posts: 1,050

Typical symptoms of a failing ignition switch.

Replace a 1979-1993 Ignition Switch Assembly
Saleen0679 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 09-11-2012, 09:04 PM   #4
Registered User

Trader Feedback: (2)
 
Join Date: May 2001
Location: Apple Valley,MN,U.S.
Posts: 112

Thank you Saleen0679. I'll try that.
__________________
1993 teal cobra
331 dart, m2 ported heads, turbo setup.
Neil J is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 09-11-2012, 10:58 PM   #5
Registered User
 
fox88's Avatar

Trader Feedback: (9)
 
Join Date: Jul 2012
Location: Pa
Posts: 3,459

Garage
Your reverse lights are prob. out as well. You can simply tie a big zip tie around the switch to hold it back together, or just buy another one from the parts store. They're only about $20 or so. There's little plastic tabs on the ends that snap off and it just hangs there, causing problems.
fox88 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 09-12-2012, 03:14 PM   #6
Registered User

Trader Feedback: (2)
 
Join Date: May 2001
Location: Apple Valley,MN,U.S.
Posts: 112

Well; after some more under dash looking, I found that one clip for the radio worked loose. After reconnecting it the radio now works. But no horn or turn signals. I also replaced the ignition switch and no change.
__________________
1993 teal cobra
331 dart, m2 ported heads, turbo setup.
Neil J is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 09-12-2012, 04:39 PM   #7
Registered User

Trader Feedback: (2)
 
Join Date: May 2005
Location: Yakima, WA
Posts: 1,050

Looks like you may have all separate problems. You might have to break out the multimeter. The horn is powered off of fuse 16 and feeds the horn relay which feeds the horns. It could also be the contacts in the steering wheel.

Saleen0679 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 09-12-2012, 10:41 PM   #8
Registered User
 
Jesse H's Avatar

Trader Feedback: (14)
 
Join Date: Nov 1999
Location: New Market, MN
Posts: 1,183

After you took it to the track it realized it's a race car. You're screwed!
__________________
'91 coupe & '93 cobra. Ones fast & the other shows well!
http://www.youtube.com/watch?v=q5QFCS9g44A
N/A 363. Hydraulic roller cam, Twisted Wedge heads, Box-R intake. 10.31@133.7. 1.61 60'... More to come.
https://www.youtube.com/watch?v=Gxl54aGMNxg&list=UULNz5S5ner5VMQ74ExR_3AQ
Jesse H is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 09-13-2012, 07:35 PM   #9
Registered User

Trader Feedback: (6)
 
Join Date: Oct 2010
Location: Astoria NY
Posts: 1,331

Wheres the relay for the horn located? Mine works with the ignition off but not on, but I can hear it clicking.
__________________
92 GT w/Stock Block 347 @ 10.2:1, Flat Top forged probes with forged eagle crank and H beam rods, Canfield 195's with Ed Curtis LS1 springs, Buddy Rawls custom hyd cam, Tmoss ported Victor 5.0, 42lb injectors, 75mm Edelbrock TB, 90mm SCT2400, QH
Reverb is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 09-13-2012, 08:22 PM   #10
Registered User

Trader Feedback: (2)
 
Join Date: May 2001
Location: Apple Valley,MN,U.S.
Posts: 112

And more scrutinizing found a nice cylindrical fuse in my glove box. Found the plug for it and you guessed it, the blinkers work. Now I just need to find the horn relay. Thanks everyone for all the suggestions.
@ Jesse-just fixing the blinkers will pick me up a tenth of a second.
__________________
1993 teal cobra
331 dart, m2 ported heads, turbo setup.
Neil J is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 09-13-2012, 08:56 PM   #11
Registered User

Trader Feedback: (2)
 
Join Date: May 2005
Location: Yakima, WA
Posts: 1,050

Horn relay is located to the left of the radio. It's mounted on a bracket with the warning chime and another relay. The horn relay is usually brown in color.
Saleen0679 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 09-15-2012, 01:10 PM   #12
Registered User

Trader Feedback: (2)
 
Join Date: May 2001
Location: Apple Valley,MN,U.S.
Posts: 112

Thanks for all advice! I found my horn relay. It was where Saleen0679 said it was. It is brown in color. The relay itself was missing. Ordered a new one and works now. Thank you Corral!!
__________________
1993 teal cobra
331 dart, m2 ported heads, turbo setup.
Neil J is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:21 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
© 2010-2011 Corral.net

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.