New C4 is slipping - Ford Mustang Forums : Corral.net Mustang Forum
Go Back   Ford Mustang Forums : Corral.net Mustang Forum > General Tech Forums > Drag Racing

Corral.net is the premier Ford Mustang Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-24-2011, 07:25 PM   #1
Registered User

Trader Feedback: (24)
 
Join Date: Oct 2007
Location: Buffalo NY
Posts: 591

New C4 is slipping

Ended up being forward clutches and converter.

Last edited by PSST-GT; 08-13-2011 at 10:36 AM.
PSST-GT is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-24-2011, 08:43 PM   #2
Registered User
 
Steve03's Avatar

Trader Feedback: (29)
 
Join Date: Jun 2004
Location: Round Lake, IL
Posts: 1,532

first, make sure your cable is 110% spot on, if you are a hair off, third will slip or eventually not engage. i had to remove the cable from the trans, (first put the car in 3rd) and make sure the lever is all the way back, then adjust the cable length to match it perfectly to where it was at. C4's a VERY touchy about this. If that is good and still having the flare at 3rd, adjust your int. band (on drover side IIRC), loosen the jam nut and trq stud to 10ft/lbs and back off 2 full rotations and tighten back down the jam nut, that should be one of your issues
__________________
Steve
`03 GT

Last edited by Steve03; 07-24-2011 at 08:46 PM.
Steve03 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-24-2011, 08:46 PM   #3
Registered User

Trader Feedback: (24)
 
Join Date: Oct 2007
Location: Buffalo NY
Posts: 591

I'll check all that stuff but it slips in 1st 2nd and 3rd.
PSST-GT is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-24-2011, 08:51 PM   #4
Registered User
 
Steve03's Avatar

Trader Feedback: (29)
 
Join Date: Jun 2004
Location: Round Lake, IL
Posts: 1,532

start with what i gave you and get back to me, i just rebuilt my own C4 (and just traded it), very simple trans.

is the trans fluid look burnt? I like to add a bottle of lube gaurd to mine. i run Dex/Merc fluid since i streeted it, type F is good too
__________________
Steve
`03 GT
Steve03 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-24-2011, 09:08 PM   #5
Registered User

Trader Feedback: (24)
 
Join Date: Oct 2007
Location: Buffalo NY
Posts: 591

The fluid smells burnt but doesn't look burnt. I'm rinning Dex/ Merc.
I'll double check the other stuff.
Thanks
PSST-GT is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-27-2011, 07:04 PM   #6
Registered User

Trader Feedback: (6)
 
Join Date: Jun 2009
Location: south, us
Posts: 1,094

slips in low, 2nd, and hi = smoked forward clutch. I assume it doesn't slip in reverse?
__________________
'93 LX 2.3-T5-cheap daily driver
toddturbo is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-28-2011, 07:53 PM   #7
Registered User

Trader Feedback: (24)
 
Join Date: Oct 2007
Location: Buffalo NY
Posts: 591

no slipping in reverse. I pulled it out today and took it to a performance tranny shop.
PSST-GT is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-28-2011, 08:29 PM   #8
Registered User

Trader Feedback: (51)
 
Join Date: Mar 2008
Location: Phoenix
Posts: 2,669

Damn that sucks. I hope its something simple that can be fixed inexpensively. I have a Redneck C4 with reverse VB sitting on the floor next to the car waiting to be installed. I sure hope mines not a pos too.
__________________
92 Hatch On3 Turbo, T56
92 Vert 349 Lunati Stroker T5
87 Gt Eddy HCI T5
87 Notch in progress
fmyth is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-29-2011, 07:04 AM   #9
Registered User

Trader Feedback: (24)
 
Join Date: Oct 2007
Location: Buffalo NY
Posts: 591

Quote:
Originally Posted by fmyth View Post
Damn that sucks. I hope its something simple that can be fixed inexpensively. I have a Redneck C4 with reverse VB sitting on the floor next to the car waiting to be installed. I sure hope mines not a pos too.
Well I hope you have better luck with it than me.
I was more pissed about having to take it back out and then putting it back in when it's fixed. Not too much fun doing them on your back.lol
PSST-GT is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-29-2011, 08:05 PM   #10
Registered User
 
splitblock302's Avatar

Trader Feedback: (0)
 
Join Date: May 2010
Location: Hampstead,md
Posts: 829

Just went through my redneck c4 after 4-5 years of abuse replaced the frictions and steels new gaskets works great/make sure they replace the shifter lever seal sometimes gets overlooked. Also I know redneck puts a small freeze plug in place of the downshift rod make sure this is in there good I had mine come out and end up laying on the valvebody.
__________________
87 hatch c-4,pump gas 408w,10.61 at 128 N/A on trans brake at 4k/10.68 at 126 on footbrake flash from 1600/hoosier QTP /as it sits street legal with tags/ FTI cam 3.90 spool sounds like a kitten,thanks Ed-FTI

THAT SH-- AIN'T FAST RACING /RANGERS LEAD THE WAY RagingA$$holeNeverGetsEnoughRest
splitblock302 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Old 07-30-2011, 08:47 AM   #11
Registered User

Trader Feedback: (24)
 
Join Date: Oct 2007
Location: Buffalo NY
Posts: 591

Quote:
Originally Posted by splitblock302 View Post
Just went through my redneck c4 after 4-5 years of abuse replaced the frictions and steels new gaskets works great/make sure they replace the shifter lever seal sometimes gets overlooked. Also I know redneck puts a small freeze plug in place of the downshift rod make sure this is in there good I had mine come out and end up laying on the valvebody.
Cool Thanks for the info!!!!
PSST-GT is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Mustang Forums : Corral.net Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 12:59 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.5.2
© 2010-2011 Corral.net

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.